Support » Plugin: Gravity Forms Entries in Excel » Can’t disable fields

  • Resolved jhultqvist

    (@jhultqvist)


    Hi Doeke!

    I can’t seem to disbable fields in the editor. I guess I am supposed to click one of the icons (arrow or x) to change it but they are not clickable. Am I doing something wrong?

    Thanks for a great plugin!
    Jesper

    WP: 4.9.8
    Php: 7.0.31
    Gravity Forms: 2.3.3

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Doeke Norg

    (@doekenorg)

    Hi Jesper,

    Sounds like you have a JavaScript error. Can you checkout the developer console?

    Thread Starter jhultqvist

    (@jhultqvist)

    You are correct! πŸ™‚

    I have “Uncaught SyntaxError: Unexpected identifier”. Does that help you?

    Jesper

    Plugin Author Doeke Norg

    (@doekenorg)

    Unfortunately not really. Do you have ANY other plugins active? If so, please try and disable those and try again. I’m pretty sure this error is coming from somewhere else, and messing up the javascript for this form.

    Thread Starter jhultqvist

    (@jhultqvist)

    Ok, I do have other plugins active. I’ll test and report back.

    Jesper

    Plugin Author Doeke Norg

    (@doekenorg)

    Hi Jesper, any update on this? Let me know if you need help. Thanks!

    Thread Starter jhultqvist

    (@jhultqvist)

    Hi!

    I have deactivated all plugins (a few at a time) and I still can’t disable any fields in your plugin. πŸ™

    Jesper

    Plugin Author Doeke Norg

    (@doekenorg)

    Please send me an export of your form (without data) using gravity forms export page. You can send it to wordpress@doeken.org. I’ll take a look.

    Plugin Author Doeke Norg

    (@doekenorg)

    Also. What browser are using?

    Thread Starter jhultqvist

    (@jhultqvist)

    Chrome for mac version 68.0.3440.106. Same results in Safari. I’ll send export later tonight.

    Thread Starter jhultqvist

    (@jhultqvist)

    Thanks for all your help Doeke! It seems your plugin is working just fine! πŸ™‚ Something is a bit broken on our site though. A site specific issue. I’ll have someone take a look at it!

    Thanks!
    Jesper

    Dear Doeke,

    I am using your plugin but I have the same issue as Jesper. I can’t disable the field because the arrow and x icon are not clickable. I have checked no javascript error, I tried to deactivate all pluginS except gravity form and your plugin but still with the same issue. I also tried to run the wordpress on internet explorer and firefox (I am using google chrome) but still does not work. My wordpress version is version 4.9.8., my gravity form is version 2.3.5, my PHP version is 5.6.38, I hope you could help me out on this one.

    I am looking forward to hearing from you soon again.

    Many thanks and regards,
    Dodi

    Plugin Author Doeke Norg

    (@doekenorg)

    Hi @dodicrossanda,

    Sorry to hear this. Unfortunately, with Jesper we came to the conclusion that there was something wrong with the theme itself. So some code in the functions.php.

    It sounds like the same could be true for you. You could try to change the theme, and try again.

    The plugin registers 2 files in the backend. A js-file, and a css-file. Since you can’t click the icons, and have no error, that means that the file gfexcel.js is missing in the body. That means that somewhere along the lines, something, a theme or a plugin, is messing with the rendering of scripts and styles. If you know of code that does that, try and deactivate that and try again. Maybe you have a script that minifies, or rearranges scripts to the footer? Anything messing with it could be the culprit.

    Hope this helps you out. Unfortunately I can’t do anything else for you. If you find out what code triggered this error, please let me know. Maybe I can prevent it somehow.

    TIP: this is what is is supposed to look like:
    Schermafbeelding-2018-10-19-om-15-25-41

    • This reply was modified 2 years, 6 months ago by Doeke Norg. Reason: added image
    Plugin Author Doeke Norg

    (@doekenorg)

    Hi @dodicrossanda,

    An update for this issue. You are not alone! πŸ™‚ Had someone else with this bug.
    So this made me review some stuff, and I think I have a fix for you. Could you provide me with an email address so I can send you a patched file?

    If this works for you to, I can release a new version with this patch.

    Hi Doeke,

    I am using your plugin but I have the same issue as @dodicrossanda. I can’t disable the field because the arrow and x icon are not clickable. (wordpress 4.9.8., Gravity form 2.3.5, PHP version is 7.1.1, theme DIVI)

    Many thanks and regards,

    JM

    Plugin Author Doeke Norg

    (@doekenorg)

    Hi @atahuwi!

    When it pours it rains right? πŸ™‚

    A new release is in the making, which contains a fix for this issue.
    Please send me a mail at wordpress@doeken.org. I’ll send you a replacement file for now so you can fix this issue.

    Edit:

    You can find the file here: https://gist.github.com/doekenorg/f0c9ecb0351ee22a79a8aa3df1429a1e

    Whay easier, and for anyone else who has the same problem: use this file, or update to 1.5.4 (when available).

    • This reply was modified 2 years, 6 months ago by Doeke Norg. Reason: Added link to fixed file
Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Can’t disable fields’ is closed to new replies.