Support » Fixing WordPress » Can't disable comments / pingbacks on pages in 3.1?

  • Resolved pixelnated


    After upgrading the section in the admin panel that let you enable/disable comments and pingbacks on pages seems to be gone.

    Has it moved elsewhere or is it just missing?

    Thank you

Viewing 7 replies - 1 through 7 (of 7 total)
  • just upgraded a local copy and confirmed that those options do vanish from the page edit screen upon upgrade to 3.1.

    I can only assume it is either in a new location I can’t find yet (help) or a bug (again help)


    I’m seeing the same thing after upgrading to 3.1. If the setting is still in WP, it’s well-hidden 🙂

    Thanks for checking @bbrewer!
    This is starting to look & feel like a bug. 🙁

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep


    3.1 hides some screen options on posts & pages edit screens by default. Just turn on the ones you want.
    More info here:

    Alternately, put this in your theme’s functions.php if you want the custom fields to show up by default:

    // Change what's hidden by default
    add_filter('default_hidden_meta_boxes', 'be_hidden_meta_boxes', 10, 2);
    function be_hidden_meta_boxes($hidden, $screen) {
    	if ( 'post' == $screen->base || 'page' == $screen->base )
    		$hidden = array('slugdiv', 'trackbacksdiv', 'postexcerpt', 'commentstatusdiv', 'commentsdiv', 'authordiv', 'revisionsdiv');
    		// removed 'postcustom',
    	return $hidden;

    (By the way, if you ever customized yours, that’s why they didn’t vanish. It only changed for people still using default.)

    Thanks for posting this, Ipstenu. That’s exactly what I needed.

    Thank you Ipstenu!!! You have made my day

    Thank you, thank you, thank you. Thought I was losing my sanity… or had a plugin conflict. You made my day!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can't disable comments / pingbacks on pages in 3.1?’ is closed to new replies.