WordPress.org

Support

Support » How-To and Troubleshooting » Can’t Delete Posts

Can’t Delete Posts

  • I am having a heck of a time trying to delete several published and draft posts. I have tried deleting from the Drafts page, from the All (Published) page, as well as trying to delete the post from within the post itself. In addition, I have tried saving a published post as a draft, then attempting to delete, but all with no luck.

    This first happened with a 2.3 WordPress version, so I upgraded to the latest version last week. Same problem occuring now though…

    Also, when I’m in Firefox and I try to make changes sometimes, it prompts me to download the edit.php file… hello? I don’t need to download anything. What is going on?

    What gives?

    How do I delete these posts without going into MySQL?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Also, sometimes when I try to delete a post from within the post editor, I get a Page Can’t be Found error. The URL contains the post ID and a “wpnonce” variable in the query string w/ a random code (it appears).

    Am I infected, do I have a virus, etc.?

    #1. You say you can’t delete but not what happens when you try to delete. What happens?

    #2. If it’s prompting you to to download edit.php, perhaps it isn’t uploaded or got corrupted. Look and make sure it’s there and in it’s proper place and upload/reupload it.

    I can’t delete anything either all of a sudden. When I try it takes me to my 404 page. I can do all other functions except delete. Quite frustrating. Any help would be greatly appreciated.

    I had the same problem. My database was somewhat corrupted with ‘lost’ posts – so i deleted them directly from the server (table _posts) Since then everything is fine.

    How did you find these “lost” posts? I would think there are so many to go through.

    I’ve tried just creating a quick test post and then deleting it and couldn’t. Unless I do it through phpmyadmin but that is very time consuming.

    Finally fixed it. It was some code in my htaccess file. I had this line trying to block some suspicious bot/hacker activity but I guess it did something to my edit capabilities in my admin panel.

    RewriteCond %{QUERY_STRING} [^a-z](translate|declare|char|set|cast|convert|delete|drop|exec|insert|meta|script|select|truncate|update)[^a-z] [NC]
    RewriteRule (.*) – [F]

    I did use phpmyadmin. Lost posts had missing ID, or no title, or were duplicated posts. Was fearly easy to find browsing through the table.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t Delete Posts’ is closed to new replies.
Skip to toolbar