Support » Fixing WordPress » Can’t Delete Posts?

  • Hello…i’m having an issue where i can’t delete posts from the control panel. It visually disappears but when i try to go to another area of the cp it says “are you sure you want to navigate away from this page?”….when i do the post shows up again when i go back to “edit posts”…any suggestions?

Viewing 15 replies - 16 through 30 (of 34 total)
  • i had the same problem. turned off lightbox plugin and everything worked again!! definately has something to do with that prototype.js file!

    I seemed to have been having this same issue. Deleting a post visually worked but, refresh the Manage posts page and the post magically re-appeared.

    However, I fixed the issue by disabling each of my plugins, created a variety of new temporary posts, and then deleted the new posts one-by-one after reactivating plugins one-by-one. This method of elimination allowed me to find that there was a plugin, Google Sitemaps 2.7.1, that was creating this issue. This plugin, btw, was also causing a blank page to appear after creating a new post…I think. Anyways, if any of you are running this plugin, you might try disabling it. If not this plugin, then you might try the same method of elimination with your other plugins. Post back if my explanation didn’t make sense.

    Thanks,
    J

    i just installed wordpress 2.2 from scratch and i’m experiencing the same problem. no theme or anything, imported my blog from blogger and can’t delete the “hello world” posts . (except with what incrementalist suggested, which is handy right now but a not quite useful in the long run…).

    Same here. Fresh 2.2 install with fantastico. Can’t do nothing. Remove posts, comments, add users, etc.
    Anyone with a step by step (for dummies) solution?
    2.1 worked like charm. 🙁

    I’m experiencing the same with 2.2
    Is there any solution in the forums…I could not find any?

    In the Manage page, the list is updated by Ajax script. A problem there is that a lot of servers block the headers of the updated lines.
    try to add a .htaccess file in your wp-admin folder with the following lines:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    macbrink, I don’t understand your .htaccess solution and would like to know more before I change my .htaccess in case of a security problem.

    The Google Sitemaps plugin is definitely causing this problem in my WP install as well, so a better solution than deactivating the plugin every time I want to delete a post would be nice.

    macbrink,
    your solution to add an .htaccess file to the wp-admin folder with

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    did the trick for me. My WP 2.2 was completely screwed up, Dashboard was a mess showing the index page all over the place, I couldn’t edit posts, delete or create categories and sometimes was thrown out to the admin login screen for no apparent reason. I don’t fully understand the fix but I know it’s a problem with Ajax and some servers. I spent a lot of time blaming my host for this but they couldn’t supply an explanation.
    Thanks.
    Seoras

    Я знаю и вам не скажу!!!!

    @sideiron: the solution you linked to from itmilk.com worked for me as well.

    summary: make sure the URL you have set for wordpress(and blog) in the ‘Options’ tab is the same as the URL you may have your .htaccess file redirecting to.

    For me, I was redirecting http://www.domain.com to domain.com, but in the ‘Options’ tab I had my WordPress URL set as http://www.domain.com, which was throwing off the AJAX script for deleting posts/pages.

    you guys saved my butt. The itmilk.com solution worked for me.

    My blog is scheduled to go live tomorrow and found this bug today. 60 authors all raring to go. I would have been dead meat if I couldn’t get this working.

    Whew.

    Thanks a lot guys, itmik.com solution worked for me too, as i wasnt able to delete posts or categories

    I too couldn’t post, edit, delete, and sometimes, even log in to WP.

    As summarized by Kallywag, I was re-directing to http://www.domain.com in my .htaccess file, and the Fantastico (automatic) install of WordPress had input the non-www version of the URL under ‘Options’.

    Once I put the correct url in there, all functionality was restored.

    you can do it

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘Can’t Delete Posts?’ is closed to new replies.