Support » Plugin: Advanced AJAX Product Filters » Can’t delete plugin completely so can re-install it clean?

  • Resolved SforSteph

    (@sforsteph)


    All of a sudden, the plugin stopped working properly. The radio buttons aren’t staying selected when they’re active, and if you try to select more than one option, the filters don’t work. I tried the plugin on a different site and it works properly as expected.

    So I wanted to delete the plugin from the site it’s not working on, and set it up fresh so I can see if it’s something wrong with my theme or something I checked that I shouldn’t.

    I’ve deleted the plugin via the Plugins dashboard page twice and then re-installed it – yet every time, in the widgets page I’m still seeing the previous filters (eg Brands (ID:148) / Brands (ID:199) / Brands (ID:175) ) from everytime I’ve re-installed the plugin and set up a new filter for Brands.

    Which leads me to think that something is still being stored in the database – and this might be causing the plugin to not work properly. I had a look in phpMyAdmin and deleted the one row that referred to Berocket – but that still didn’t delete the old filter showing up – nor did it fix the plugin issue.

    Any ideas? This is a great plugin and I’d love to get it working on my client’s site.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Dima Holovnia

    (@dholovnia)

    Hello,

    Please provide your site url.

    Regards,
    Dima

    Hi, it’s a client’s site and I warn you there are NSFW adult-content products in the store!!!

    https://drnikkishop.com.au/shop

    Plugin Author Dima Holovnia

    (@dholovnia)

    All I see there is

    Dr. Nikki Shop

    New site coming soon…

    Sorry, I thought I had turned off maintenance mode. Should work now!

    The filters are on the Shop page.

    • This reply was modified 11 months, 4 weeks ago by SforSteph.
    Plugin Author Dima Holovnia

    (@dholovnia)

    I did check it and there is an issue with radio. I’ll ask our tester try to reproduce the issue locally.

    I’ll update you asap on the progress.

    Thank you.

    Hi, any ideas on when I can get this working? Or how I can completely delete the plugin from the site, so I can reinstall it fresh to see if that fixes it?

    Thanks!

    Plugin Author Dima Holovnia

    (@dholovnia)

    We are still testing it. We will update you on the progress.

    Plugin Author Dima Holovnia

    (@dholovnia)

    Hi,

    Could you please change radiobox for the mobile to drop-down?

    I think the problem is that both desktop and mobile are using radio and radio can be only 1 on the page.

    Regards,
    Dima

    Thanks so much for all your help – I changed the filters to checkbox not radio, and it seems to work now!!

    Plugin Author Dima Holovnia

    (@dholovnia)

    There is another option. You can continue using radio everywhere. BUT you must use for desktop and mobile different filters.
    Just create duplicates of the filters. One version add to one group, second version of filters to another group.
    First group configure for the desktop and second for the mobile.
    This way you can use radio, drop-down or anything else in both locations.

    • This reply was modified 11 months, 3 weeks ago by Dima Holovnia.

    I’m happy to use checkboxes, especially with the designs you offer in the plugin (so they don’t look like boring normal checkboxes). Thanks again!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can’t delete plugin completely so can re-install it clean?’ is closed to new replies.