Support » Plugin: BuddyPress Xprofile Custom Field Types » Can’t delete field

  • Resolved brunov99

    (@brunov99)


    Hi there,

    I tried to test BuddyPress Xprofile Custom Field Types plugin for the first time and I made a very first field named “Birthday” in the Group called Base. This field has been marked as “Primary” (First I don’t know what it refers to) and I can’t delete it.
    I tried also to move it to another group I made (not Base group) and I can’t delete it either.

    Can you please tell me how can I delete it and what is the “Primary” badge signification and purpose ?
    Thank you,
    bV

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Brajesh Singh

    (@sbrajesh)

    Hi bV,
    I am sorry, It seems there is something wrong with your installation.

    The field primary is used for “Full Name” and it should be created out of the box by BuddyPress. Why is this new field called primary is beyond me.

    Did you use some custom code for modifying/deleting your Full name field as BuddyPress does not allow deleting the primary field out of the box.

    Hi,
    Thanks to answer.
    No I did not change anything. It’s a normal buddypress/bbpress plugin installation with a bunch of plugins but…
    Well, I’ll try some desactivation / activation and come back asap.
    Thx
    bv

    Well, I’m a bit confused.
    I made a fresh install of bbPress without your plugin and this field appears again.

    Base (Primary)
    Name (Primary) Required.

    So I go to the buddyPress forum to check it.
    Thx anyway.
    bV

    • This reply was modified 1 year, 3 months ago by brunov99.

    Ok,
    after looking at the url and searching Google I understood that this field is related to the BuddyPress “User Unique Name” aka buddyPress username or pseudo (so that’s a bit confusing).
    The field is open to customize its label once for all.
    That’s why I cannot change or delete it after.
    So nothing to do with your plugin.
    Thx bV

    Plugin Author Brajesh Singh

    (@sbrajesh)

    Hi bV,
    Thank you for the updates. I am glad you resolved it.

    Best regards
    Brajesh

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can’t delete field’ is closed to new replies.