Support » Plugin: Pricing Table » Can't delete Feature

  • exgreen7

    (@exgreen7)


    If I need to change the wording or delete a feature, sometimes it will not let me.
    I’ve had to do a whole new price table. What causes this delete feature bug, and is there a workaround?

    I have a price table with 4 columns and 8 Features. Don’t want to have to keep redoing it.

    Thanks,
    Ed

    http://wordpress.org/extend/plugins/pricing-table/

Viewing 7 replies - 16 through 22 (of 22 total)
  • Just to clarify….

    In each instance of replacing..

    str_replace(" ","",$str);
    with
    preg_replace("/[^A-Za-z0-9]/","",$str);

    You need to make sure the $str is the same as the one replacing, there’s no blanket find and replace you can do for the file as the $var the string replacement is working on varies. Make sure the preg replace applies to the same $var as the str_replace was.

    Hello all, I am new to this plugin.

    I read many of the comments here and in other post. I performed a test, I added packages and features and saved them. I viewed them on the front end using the green template and I was happy with the results. Then I did some testing by deleting packages and features, saved them and viewed them on the front end. All works well I can’t find any issues. The theme that I am using is Suffusion. WordPress version is 3.5.1. And this is my test site where I have many plugins that I constantly test for revisions, updates and compatibilities.

    So if some of you are having problems deleting features, may I suggest that you test a different theme like the default theme that you get when you install WordPress 3.5.1 and if that does not work disable all the plugins and run another test. I suspect that you might have a compatibility problem with plugins or themes.

    I hope this helps anyone here.

    Kind regards

    @davidollerhead I appreciate your input, it helped me a lot. of course I had to ensure that the variable in the line matches what i am replacing.

    preg_replace("/[^A-Za-z0-9]/","",$<replace_variable_name>);

    @davidollerhead

    Thanks for your help with this issue. I made the change you suggested and it is working properly now! I really appreciate it.

    For others, I found just 3 instances of the code that needed to be changed. The “find and replace” feature doesn’t work as someone else stated.

    You just have to manually search for str_replace(” “,””, and then make the change Dave suggested.

    Can someone help me out — I’m not quite understanding this hack. I see 3 instances of str_replace @ lines 76, 90 an 96.

    So like 76, for example is:
    str_replace(" ","",$value);
    I replaced it with:
    preg_replace("/[^A-Za-z0-9]/","",$str);

    And line 90 is:
    str_replace(" ","",$value1);
    and I replaced with:
    preg_replace("/[^A-Za-z0-9]/","",$str1);

    Line 96 is:
    str_replace(" ","",$value);
    And I replaced it with:
    preg_replace("/[^A-Za-z0-9]/","",$str);

    What am I doing wrong? Can someone show me in more detail?

    got it. The $str in the replacement code is not $str as the first code snippet appeared to me. Just leave the values as they are and change the rest.

    I have a Feature with ‘&’ in it and cannot delete it. How can I modify the given fix above to accommodate for the ‘&’?

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘Can't delete Feature’ is closed to new replies.