The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Can't delete anything (4 posts)

  1. DaveMcK
    Posted 8 years ago #

    I have over 13,000 Akismet spams - I can't delete them.

    I can't delete links.

    I can't delete drafts.

    I haven't tried to delete posts, because I don't want to - but I wouldn't be surprised if I couldn't delete them either.

    Any ideas what's going on, and how to fix it? Is it a permissions thing? What do I need to change?

    Thanks in advance.

  2. DaveMcK
    Posted 8 years ago #

    I'd really appreciate any pointers you might be able to give on this. I have deleted WP and installed the latest version, but that did not work.

    Where are the akismet spams held? Perhaps I can delete them manually? But that would still not solve the rest of my deleting problems.

    I just need a clue...

    Thanks in advance.

  3. DaveMcK
    Posted 8 years ago #

    I have tried deleting in Safari, Firefox, and IE on the Mac, and in IE7 on the PC.

    Nothing works.

    When I try to delete a comment I get the red flash - but it just stays red, and the comment remains.

    I can't delete posts - I have tried.

    Do you think it might be an Ajax problem?

  4. DaveMcK
    Posted 8 years ago #

    OK, you can all stop panicking now. I logged into phpmyadmin and looked at the user privileges - seemed like the "delete" box for the main user was unchecked, for some reason. Checked it, and now I can delete.

    Simple, really.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.