Support » Fixing WordPress » can’t delete a comment

  • After upgrading to 1.2 my comment submit button stopped working. I found the error in the template, fixed it and posted a test comment to make sure it’s OK. but now I can’t delete the test comment. When I attempt to do so I get a page with the following error:

    Sorry, you need to enable sending referrers, for this feature to work.

    I have no idea what that means or what I should do to fix the problem. Help?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Just as an update, I get the same thing when I try to delete an entry. So now I have an ugly test post to go with my ugly test comment.

    My wordpress installation appears to be disintegrating before my eyes. Now I can’t log in. Before that I couldn’t upload images because it said it wasn’t activated although it clearly was. Just this minute, the post content disappears from the index page when called with the comment form showing (didn’t do that before). And no, I didn’t do anything to cause any of this.
    What next?

    So no one has any idea what could be causing this bug? Because it’s very annoying and not going away magically by itself.

    Have you tried the suggestions regarding turning off that particular option in the privacy settings of your firewall?

    I tried turning my firewall off altogether and it didn’t make any difference. Plus I was able to delete things before I updated and I used the same firewall. I’m pretty sure it’s a software thing because the software is what is giving me the error message. The url in the address bar is …/wp-admin/post.php?action=deletecomment&p=799&comment=2425
    I’m also now being hit with spam. Done by stupid spammers because I’m not listed in search engines and don’t have a lot of traffic but still, I can’t delete it. I can edit each comment manually to remove the offending content but that’s not really good enough.

    That should say before I upgraded. This problem came with 1.2.

    Have you tried to “enable sending referrers” as the error states?? It (sending referrers) is now used for security I believe.

    I would try it if I had any clue what it meant. Enable them where?

    what browser are u using?
    so u have ur firewall disabled? is anything else running like NIS or some proxy that might be blocking referrals?
    tried with any alternative browser?

    I’ve tried it with not only different broswers but a different computer. It’s not me. There is no proxy, nothing that could be getting in the way (that I know of). My router has a hardware firewall but it didn’t stop me deleteing things before I upgraded and has never interfered with my websurfing in any way.
    It could be something on the server where Wp is installed, but I don’t know where to even begin asking my webhost about it. The error message means nothing to me. I’m pretty sure they have register globals turned off but then they had that before I upgraded and I could delete stuff then.

    OK that’s weird. I tried this with firefox a couple of days ago and nothing would delete. Tried it again now and deleted a comment fine. So it is browser specific.
    I use IE 6.0 normally and run Win 2000 if that matters. Obviously something in there is stopping me but I don’t know what. The security settings are the same as before the upgrade and are pretty minimal. I looked earlier today and couldn’t find anything about sending referrers but then MS products aren’t always obvious about what and where stuff is.
    I don’t know why firefox has changed except that I’ve been using it more recently and got things set up how I like now. So something got switched probably. I still intend on using IE 6.0 as my default though (yeah yeah, I know, firefox is so wonderful blah blah, I have reasons) so would like to fix this problem.

    I’m having the same problem. Doesn’t matter which browser I use. I have no firewall. Things worked fine with 1.2 alpha from a month or two ago. It doesn’t work with the latest version…

    I figured it out. I was using Privoxy ad filtering, and it was blocking referrers.

    If you are using privoxy then you must enable sending referrers through that. I am having the same problem and have not found out how but when I do I will post the answer.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘can’t delete a comment’ is closed to new replies.