Support » Fixing WordPress » Can’t customize the theme

  • Hello,

    I’m out of option and i’ve tried litteraly everything.

    When i try to change the color of my theme accent the change does not register. When you hit the publish button in the customizer it goes directly to plannified and the change is shown in the preview but not live.

    It’s the same with everything i try to change in the customizer.

    I’ve been in touch with my hosting and theme provider. We tried without plugin, with the default theme of wordpress, looked for bug in the log, js bug in the console. Nothing explain this behavior.

    Also this problem is happening on 2 of my site on the same server. However, i have other sites on this server and they don’t have the same problem.

    Do you have any idea where it’s coming from ?

    —NOT RELATED BUT MAYBE—

    Also, Since the update 5.3 it seems i have lost the ability to publish my article directly it goes to be planned. Sometimes, i have a message error where the plannification did not go through, i have to schedule the plannificatio an hour later for the post to show….

    Cordially,

    • This topic was modified 1 year, 7 months ago by tomiino92.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Customizer is programmed by the theme developer. The information is usually stored in the theme option database as either a theme option or just an option depending on how the customizer was programmed. If you are having the same problem with the same theme on all of your sites, You probably need to talk to the theme developer. WordPress doesn’t add customizing options to a theme it up to the developer to add these functionalities and maintain them.

    Thread Starter tomiino92

    (@tomiino92)

    It’s not about the theme it’s about the customizer it’s the same problem if i use twenty-twenty or another theme. It is not theme related, it is with the customizer. WordPress comes with a built-in theme customizer.

    Since wordpress is hosted on over 37 million websites it unlikely the error is with wordpress. If it was a coding error with wordpress there would be thousands or millions of sites having the same problem not just yours. Have you tried the same setup on a localhost or on a different server. It more likely a hosting issue then a wordpress issue. Customizer stores it options in the options table of wordpress. You can try looking in that table to see if the values are getting stored. Even know the customizer api is part of wordpress each theme developer decides what options they want to use and how they are going to be stored. If you have 2 different themes they are probably using different values to store the customizer information. If you change from theme to theme the customizer information doesn’t follow.

    Thread Starter tomiino92

    (@tomiino92)

    Thank you for your message. I also think it’s a problem with hosting. I was just wondering if somebody already had this problem and solved it.

    Cordially,

    Thread Starter tomiino92

    (@tomiino92)

    Ok i found the solution with my hosting company. For me it was due to a conflict with the package tzdata of the server that synchronise with universal time. Hope that will help anyoe with similar issues.

    I am facing similar problem, timezone setting is correct
    but unable to publish. Can any one please help me.

    I am having the same problem. Whatever theme I install if I click on customize I just get a message saying “Your scheduled changes just published”

    I could solve the issue,
    Host server was on Asia/Kolkata (IST) time zone, after changing the zone to UTC, problem got solved.

    every thing works fine now.

    Facing same problem here on a Strato webserver Centos 7 and plesk running. Everywhere i can see on server side or wordpress all my time zone settings are: Europe/Amsterdam.

    I have a plain installation of WordPress… no caching no plugins. Nothing changes when i customize my theme settings. Neither it is plubished direct or when i plan it in the future. Also pages or articles don’t publish direct.

    I read miles of forums and support articles. Tried several solutions to get tzdata aligned via linux command input. All is set… but wordpress seems to ignore my changes.

    The funniest thing what is happening that when i enter customizer i see all of my made changes. After i “publish” or plan it in the future. The website isn’t updated. Even when worpress tells me “Your scheduled changes just published”. Does anyone have a clue it drives me mad?! Thanks guys!

    @robhoutkamp Ik heb hetzelfde exacte probleem. Heb je al een oplossing?

    @danielbrinks Unfortunately no. Still hours busy searching for a solution. All of my hosted websites on Strato have this problem.

    They all have a clear log on “Site health checker” plugin. Except mariadb is stated to be outdated. But that can’t be the problem i hope. Since upgrading to mariadb 10 isn’t supported by plesk, i don’t want to do it “myself” because everything is running quite good and may be this feature will be in a next update of Plesk Obsidian.

    Are you also running at Strato? What did you try?

    I have tried everything you did. I use plesk with centOS 7 at work and it just works and this doesnt. I have no clue why. I have the same setup at TransIP and it just works as well.

    This is a problem on strato’s side. We need to contact the helpdesk.

    I have solved the problem @robhoutkamp
    Change your server to Ubuntu 18.04 + Plesk

    Thank me later 🙂

    I am having the same problem… Anybody out there with a solution or something to try?

    The problem is CentosOS7 related. The UTC time file is wrong or causes the issue with wordpress.

    following this link:
    https://talk.plesk.com/threads/utc-time-issue-plesk-php-7-3-7-4-on-centos7.356169/

    and then this link:
    https://talk.plesk.com/threads/utc-time-issue-plesk-php-7-3-7-4-on-centos7.356169/

    I found that you need to replace the /usr/share/zoneinfo/UTC file. The second link contain a file that you can use to replace (you have to register to be able to download). As described after replacing the file you can immediately publish in wordpress without reboot of the server.

    Hope this will help some of you!

    • This reply was modified 7 months, 1 week ago by alexllll.
Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can’t customize the theme’ is closed to new replies.