Support » Plugin: Hyyan WooCommerce Polylang Integration » Can’t create product categories

  • Resolved RikuAnsem

    (@rikuansem)


    Hi.
    I have the latest WordPress version (4.7), woocommerce 2.6.9, polylang 2.0.10 and Polylang Integration 0.29 (I tried all with the previous version except polylang integration and fails too).

    When I try to translate a category, it fails everytime (I tried into a clean WordPress installation too).
    I don’t show any error message, only refresh without changes and create nothing.

    Thanks for support.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,

    Can you please elaborate what you mean with fail to translate a category? Please describe step by step what you are doing and in what admin page., so that we can help.

    Cheers

    Hi.
    First of all, sorry for the title, is not “create”, is “translate”.

    I’ve updated all Plugins to current date and it still fails

    The process:
    1- Products -> Cateogries
    2- Create new category with the default name, and set the name in translation.
    3- Add category (it don’t do the translation)
    4- Add “translation” (it directly don’t load anything)
    5- Edit –> Set translation (it don’t do anything too)

    This is all the process.
    I tried in a clean wordpress too.

    Thanks in advanced

    To create a new category, in step 2, you create the category in the language set in the dropbox just below the Thumbnail field. The Translation field you can leave empty at this point. Click the button “Add New Product Category” and it should be added to the list on the right hand side (if not, just refresh the browser).

    Now that you located your new category on the list to the right, you need to add the translation. Click on the plus signal for one of the other languages your site supports. The plus signal is under the column with the flags. If it is not there, it can be added in the Screen Options on the top of the screen.

    After you click on the plus, you add the translation – just like you did before to create the new category – You will notice that the Translation field this time has the name of the category you created in the step before.

    Let me know if this helps.

    Hi.
    Thanks for you reply

    Step 4 is just the flag column.
    I recorded a video to show the problem with all input possibilities:

    Regards.

    When you press the plus sign to add the translation DON’T click edit afterwards.

    Note that just after you click the plus sign at this point in the video, the language field in the form on the left hand side changes to Spanish. Your video doesn’t show, but if you scroll down you will see in the Translations field the flag English and the name “Test Category”.

    So, after you click the plus sign (DON’T click edit) just fill in the form with your translation name and slug, i.e. “Categoría de prueba” and “prueba”. And of course click the button to save/add.

    This is pretty much standard Polylang functionality. Nothing to to with this plugin.

    Oh, thanks, it works!

    I think that I tried it a week ago (I don’t remember), but it works now, this is the important thing.

    Thanks for all!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t create product categories’ is closed to new replies.