Support » Fixing WordPress » can’t create posts

  • Resolved bvo

    (@bvo)


    Hi all,

    On WP 5.0.2 and twenty nineteen

    I can’t create a new post. I read this post bij jpgjpg and reinstalled WP and deactivated all plugins, but no result.
    When I save a new post the title disappears and says something like “saved automatically” and when I preview the post I get a 404.
    When I look in phpmyadmin, I do see a new draft, so something did happen.

    I’m wondering if something is realy messed up because I also can’t upload pics (this topic).

    Hope someone can help me here
    Kind regards,
    Bas

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator bcworkz

    (@bcworkz)

    Be sure the REST API is working correctly. A browser request like example.com/wp-json/wp/v2/posts should return a long list of JSON formatted post data. The API is used more and more by default WP and its failure can result in bizarre behavior.

    Server security modules like mod_security can also cause strange behavior. If any such module is running, you’ll need assistance from your host to resolve the problem.

    Thread Starter bvo

    (@bvo)

    Thanks Bcworkz,
    Json seems to work correctly, since I do get a long long list of all my posts.
    About the other part, the funny thing is, it worked before. Actually it worked untill the wp5 update. I didnt change anyrhing else then updated to wp5. No changes in serverconfiguration, in plugins, in htaccess or whatever. I do run my own (synology) server.
    Hope someone has some other ideas?!

    Moderator bcworkz

    (@bcworkz)

    Be sure all of your folder and file permissions are correct. Do you have a somewhat recent version of PHP and DB server? https://wordpress.org/about/requirements/

    Try the health-check plugin. It’ll flag a number of potential problems when found. You’ve already manually done what the troubleshooting mode does, but the status tab might flag a potential problem.

    Thread Starter bvo

    (@bvo)

    Hi Bcworkz,
    I checked the folder permissions, maybe this was not correct for the child theme I made for 2019, but correcting it, doesn’t solve my problem 🙁

    I use a synology server (6.2), wich had PHP 5.6 and 7.0 installed. I told the server to use 7, but the health check says I use 5.6?! The synology has DB5.5 and DB10. My server runs on DB5.5; I didn’t succeed in transferring it to DB10.

    The health plugin reports, other than PHP en DB: “The REST API request failed due to an error” and ” The loopback request to your site failed, this may prevent WP_Cron from working, along with theme and plugin editors”

    Any suggestions how to move forward?
    BTW, everything worked perfectly before the WP5 update!

    Moderator bcworkz

    (@bcworkz)

    The new block editor requires the REST API in order to work. Previous versions of WP tolerated it not working. A lot of people have previously disabled the API out of misguided security concerns. This is done through a bit of code added to a plugin or theme. It could also be disabled external to WP through a .htaccess rule or a rule in modSecurity.

    Maybe you should try the health check troubleshooting mode anyway. If you can save posts in this mode, there is some disabling code hidden somewhere in your theme or plugins. Selectively reactivate (through admin bar troubleshooting item) to find out which. If saving still does not work, the disabling code is external to WP.

    Failed loopbacks indicates an improper server configuration that could hinder updates from working correctly. Start finding a fix by confirming the user PHP runs as has read/write permission for all files and folders.

    Thread Starter bvo

    (@bvo)

    Thanks again,
    I troubleshooted with the health plugin: with all plugins disabled and default theme, the loopback error and the api error are gone. Seems that my captcha pluing causes this problems.

    So all pluging’s reactivated, but not the captcha, it passes the health test, of course except the php en DB warnings.

    However, a I still can’t create a post of insert a (block) album. I got the same outcome.

    By the way, I do see an error message in/behind/over the editing screen that says “notice undefined index path in …/l10n.php on line 919”. I don’t know if this has anything to do with my current problem, but it started after updating to WP5 just like the post creation problems.

    So all tests are good, but the outcome isn’t? What’s next? I checked the server, there is no user php. Synology uses a user called http (and a group http). I think that’s like your user php?

    I’m thinking if I can’t find the problem, maybe I should export the whole site, deleting the database, uninstall WP, and start al over, on DB10 and (hopefully) PHP7, and WP5 from the beginning. And then import back the post, comments etc. Will that work and does it help?

    Moderator bcworkz

    (@bcworkz)

    Heh, not the user named “PHP”, the user name that PHP runs under 🙂 User “http” is a possibility and not unusual. The user to check permissions of is really the one the web server runs as. The web server in turn runs the PHP interpreter. There ought to be a server configuration file somewhere where the user name is specified.

    It’s sounding like there are multiple issues that need to be resolved. The undefined index error is due to some registered script loading translation text domains incorrectly. Getting the results of debug_backtrace() when the error occurs is needed to find out the source of the error. Or by trial and error through selective activation like how you found the Captcha plugin issue.

    I think a re-installation without changing anything will end with the same results. I suppose its worth a try if there seems to be no other place to look for issues. I would first try simply replacing all current WP core files with those from a fresh download. It’s not unheard of for updates to corrupt a file somewhere. Be sure you have the latest versions of all plugins and your theme. There were a large number of plugins that required updating to maintain compatibility with WP 5.0.x

    It would be telling to clone your WP installation into a more common web server like Apache. A localhost installation would be good enough. If it works there, there is something amiss with the Synology server. Something like XAMPP from Apache Friends typically isn’t too involved to get running on your local computer. Use the operating system’s hosts file to resolve whatever domain name your site uses.

    Thread Starter bvo

    (@bvo)

    I tried a lot of things, but nothing helped. So I made a backup, uninstalled WP en deleted the database. Then I created a new database (DB10 this time) en manually installed WP.
    The health plugins says everything is cool now. I imported my old posts (via WP-import, not with phpmyadmin). However, creating/saving posts still didn’t work. I uninstalled all pluging and re-installed them one by one and now everyting works fine?!
    So I guess things were messed up in the WP5 update somehow and a fresh install (on SB10 and PHP7) solved this.
    Thanks bcworkz for all your replies!

    Moderator bcworkz

    (@bcworkz)

    Phew! Glad you worked that one out. Proof that perseverance pays off.
    You’re most welcome.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘can’t create posts’ is closed to new replies.