Support » Fixing WordPress » Can’t create new users (ERROR: Please enter your password)

  • Resolved Touda

    (@touda)


    Suddenly, I can’t create new users as I did many times before, from the admin panel.

    First odd thing is that Show Password button on New User page doesn’t respond.

    Then I fill up the form, click on the blue Create New User button and then I get the ERROR: Please enter your password message.

    Another strange thing on that same page is that contextual help upper label doesn’t work either. I click on it, and it doesn’t open the drop down space with the usual help.

    I’ve looked for Javascript errors and this is what I saw:

    Error: TypeError: e is undefined
    Source File: https://www.xxxxxxx.xxx/wp-includes/js/wp-auth-check.min.js?ver=460b0829b1e2907c1afd88a5d62b8696
    Line: 1

    Might it give some clues, I’ll say that recently our hosting provider moved the whole site to another server with upper versions of PHP. I’ve set PHP down to 5.4 but the error remains.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Have you tried this by

    -Updating WordPress, Plugins, Themes
    -Deactivating all the plugins
    -Activating default theme like twentysixteen ?

    When I activate debugging through wp-config.php this is what I get on that Create New User page loading:

    Notice:  Use of undefined constant add_shortcode - assumed 'add_shortcode' in /xxxxx/wp-content/plugins/stray-quotes/stray_quotes.php on line 615
    
    Notice:  bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in /xxxxx/wp-includes/functions.php on line 3996
    
    Notice:  Use of undefined constant WPLANG - assumed 'WPLANG' in /xxxxx/wp-content/plugins/add-local-avatar/avatars.php on line 154

    -Everything is updated, except Hueman theme, but that’s not the theme in use (but a child of it).
    -I tried to deactivate only the last plugins that where updated since last user was successfully created. Sincerely, deactivating ALL the plugins scares me, for I’m not sure setting will remain and no data will be lost.
    -I’d prefer not to change theme on a live site.

    The Javascript and WP-debugging errors don’t give enough information about the source of the error?

    I think the buddy press or bbpress changes has caused the problem. Can you download the site using duplicator and switch to default theme I think the problem will be solved. It may be due to conflict in functions of bbpress or buddypress with the humane theme configuration which has the old codes of bbpress or buddypress.

    If I understand, then it’s a conflict between bbPress and an parent theme not being updated?

    BTW, thank you for the hint about Duplicator plugin, I didn’t know about it. It seems a great tool! I’ll give it a try!

    Besides, I can try to update Hueman parent theme and then see if its changes fix the problem with its child theme.

    Yaa major functions are taken from parent theme so updating it will be a great idea 🙂 and updating all themes and plugins will be also great. You can setup local or a test site for updating and doing changes and if you are using cpanel with the staging support than the pain will be much lesser 🙂

    Sadly, I’ve updated Hueman theme (the parent of the active theme) and the error remains 🙁 Now everything is updated 🙁

    I’ll try to duplicate the site using duplicator and try the deactivate-all-plugins and change-to-default-theme options in order to find out the responsible for the error (some plugin or even the theme).

    Sadly (again) duplication has failed. All I get is a blank page 🙁 Can’t see nor login to the duplicated site 🙁

    I get these errors on the error_log file at the duplicated site’s directory:

    [07-Sep-2016 18:37:47 UTC] PHP Warning:  require_once(/xxxxx/wp-content/themes/hueman/functions/init-core.php): failed to open stream: No such file or directory in /xxxxx/wp-includes/template.php on line 572
    [07-Sep-2016 18:37:47 UTC] PHP Fatal error:  require_once(): Failed opening required '/xxxxx/wp-content/themes/hueman/functions/init-core.php' (include_path='.:/opt/cpanel/ea-php54/root/usr/share/pear') in /xxxxx/wp-includes/template.php on line 572
    [07-Sep-2016 18:37:56 UTC] PHP Warning:  require_once(/xxxxx/wp-content/themes/hueman/functions/init-core.php): failed to open stream: No such file or directory in /xxxxx/wp-includes/template.php on line 572
    [07-Sep-2016 18:37:56 UTC] PHP Fatal error:  require_once(): Failed opening required '/xxxxx/wp-content/themes/hueman/functions/init-core.php' (include_path='.:/opt/cpanel/ea-php54/root/usr/share/pear') in /xxxxx/wp-includes/template.php on line 572
    • This reply was modified 1 year, 3 months ago by  Touda. Reason: additional info
    • This reply was modified 1 year, 3 months ago by  Touda.
    • This reply was modified 1 year, 3 months ago by  Touda. Reason: typo!

    Thanks to a Javascript error detected when new user page loaded, I suspect from Geo Mashup plugin. I went to its configuration and unmark the Users global setting, so it won’t try to ask for geolocation for the new user.

    Then, everything at Create New User page worked OK.

    I guess I’ll have to mark/unmark that each time I want to:
    a) Give the location for a user (mark it).
    b) Create a new user (unmark).

    Great you found the issue 🙂 Posting the error in their support page they might solve the problem causing error 🙂

    Yes, I did it. Sadly I didn’t write down the Javascript error and my browser console seems to have deleted it. I’ll have to reproduce it again 🙂

    • This reply was modified 1 year, 3 months ago by  Touda. Reason: adding link
    andymacmiller

    (@andymacmiller)

    I’m experiencing this same problem – abruptly being unable to add new users (I’m also experiencing other backend issues).

    I don’t have the Geo Mashup plugin, however. Any ideas for a broader application of the fix you made, that I can use for my own fix?

    Desperate to get this figured out, let me know if anyone has thoughts and THANK YOU!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Can’t create new users (ERROR: Please enter your password)’ is closed to new replies.