Support » Installing WordPress » Can’t create new static pages

  • Hello,

    I wonder if any of you smart people could help me with a problem. A friend has very kindly set up a Thesis wordpress site for me on her computer and has created some pages for me to get started. I then, on my own computer, attempted to add some new static pages. However, try as I might, when I publish the new page, I see the preview of it, but for some reason it doesn’t appear on my actual site. So I was advised that I should change the wp super cache status from On to Off, Update the status, go and create my new page again and then go back to WP supercache and change the status back again. I did this, several times, but still my page doesn’t load onto the actual site, despite the fact that my dashboard tells me it’s ‘published’ and actually gives me a preview of it. I am using Firefox. So I visted several wordpress advisory sites, including Hacking Kubrick, who shows how easy it is to create a new page. It was just a question of publishing it with one click! Believe me I’ve tried every combination of clicks possible on the dashboard, to no effect. My new pages remain ‘published’ but invisible on my site! I must say, it would be nice to publish some more pages, but I’ve decided that WordPress is inferior to a better system I’ve encountered, created by Dr Evoy of Sitebuild-it, who gives you easy stylish templates to work with and shows you how to ‘optimise for search engines’ from the off. But any good advice will be well appreciated. Many thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Deactivate all plugins, change to the WordPress Default Theme, then let us know if the problem persists.

    Also you might look at:

    Hi Again, Michael,

    On an entirely different WP site than the one we spoke about yesterday I’m having this problem. It’s a brand-spanking-new WP 2.8 site, and NONE of the static pages show up online. Not the about us page, and not the Dagon sitemap.

    LINKS to them show up, in the right-hand menu, and even on my custom 404 page, but those links and even typing directly always take me to the 404 error page.

    So I switched the template to Kubrick, no joy.
    I turned off all my latest plugins, still no joy.

    Just like Redulfo said, they are showing up published and exactly as I typed them when I hit “preview.” -Just not online to the public.

    The posts work fine, again, this is just static pages. What the heck could be doing this to a new, vanilla build? There are other 2.8 installs working now on this same server and even IP address, so what is the difference with this one?

    Thanks again for your help,


    I’ve been through every setting on the blog and the one setting that is different here from the other blog on this server is the permalink structure.

    Usually I use this:

    But for this blog, I’ve changed it to this:

    But now that I’ve got a few posts, I’m afraid to try changing it. Could this make any difference?

    Another Update:

    I have deleted the .htaccess file in hopes that a remade one will solve the problem. So far, no change, but I can’t tell if a new one even got recreated.

    Surely someone out there has .htaccess experience enough to tell me what’s going on here… Please?

    That’s it, I’ve HAD it…

    No matter what, EVEN AFTER REBUILDING THE BLOG FROM SCRATCH, I cannot put the year in front of my permalink structure and still get any working pages!!!

    I’ve read through every millimeter of, which is kind of out of date, by the way, and nothing addresses this. I think there is a version 2.8 bug here that is stopping that permalink structure (/%year%/%scategory%/%postname%) from working with pages.

    I’ve even tried manually inserting “/2009” into the url on pages and I still can’t get to them… But the second I switch the permalink structure over to /%scategory%/%postname% again, everything works fine.

    I guess putting the year in your permalink string is a BAD idea now. My, how times have changed!


    Oh, and in case you were wondering, the %scategory% part of the string is just the same as %category% but needed for the scategories plugin to work.

    Yes, I’ve certainly tried ripping that out and testing the structure as
    /%year%/%category%/%postname% -But it didn’t change things at all.

    It really appears that pages don’t work anymore if you use numbers in permalinks! (Or at least the specific year-category-post permalink structure.)

    I had this issue, and first, trashed my .htaccess file, then wrote a new static page. Somehow that burped things to come back, all static pages now show.

    Hi Joe, Thanks for your input.

    I just gave that a try out of desperation, but no, it did not work for my case. I even made two new pages, one while there was no .htaccess, (and tested then) and another while I added the old .htaccess file back. (Because nothing I could do would persuade it to make a new one.)

    No matter what, I can’t get it to generate the .htaccess file, and therefore, .htaccess will never correctly route ppl to the correct permalink with a Year in the string.

    I guess the problem with this blog is plain & simple: Somehow WP just won’t create a new .htaccess file. Period. Not after updating permalink settings, and not after creating new pages nor posts.

    Can anyone point me to a resource that shows me where all of the settings are that could potentially stop .htaccess creation?

    Thanks again,

    I had the static page problem too, and accidently found how to do it. Hover mouse over name of post you want as static, and choose Quick Edit.
    Tick the Make this post sticky box, and save.
    Hope this helps

    There was a problem with handling /%year%/%category%/%postname% permalinks in old sCategory Permalink. Should work now

    I had a similar problem, and it turned out that mod_security was interfering with WordPress. I contacted my webhost, they whitelisted some mod_sec rules, and now I can publish pages again.

    Has anyone found a solution to static pages being un-editable yet? I can change all posts but not pages… am I missing something?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Can’t create new static pages’ is closed to new replies.