Support » Multisite » [Resolved] Can't create new sites on network

[Resolved] Can't create new sites on network

  • I’ve installed the network yesterday, everything seems fine and I got the proper wordpress network panels generated on the dashboard, the original domain seems to be working properly too. However when I tried creating a new site, http://asia.facekitt.com/, I get an error.

    I searched other parts of this forum, it tells me to get my host to do something about my .htaccess, but I have gotten their help to no avail.

    I am on dreamhost, and I used the one click install, here are the other information

    This is my htaccess file

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    This is my config file

    /* That's all, stop editing! Happy blogging. */
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'facekitt.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
Viewing 10 replies - 1 through 10 (of 10 total)
  • I had seen from others on here that in order to do the multisite subdomain you could not use the one click installs on most of the hosts as they had some preconfigured settings… you had to do the install manually… that is what I had to do on my host…
    Others more experienced may confirm though…

    ahhh… I am slightly in a situation right now, my original blog has about 300blog entries, i’m not too technically inclined to recreate a new blog and transpose all the old information in. 🙁

    is there a better way to resolve this?


    Dude! You just PUBLICLY posted your password! Never do that! Ever! Go! Right now, change the password for SQL, and while you’re at it, FTP. That is so crazy dangerous! Never do that again! No matter what.

    Also change your Salts and keys: https://api.wordpress.org/secret-key/1.1/salt/

    Seriously, this is not a joke. Do that before you even THINK about doing anything else!

    Done? Okay.

    You can convert a one-click install into multisite in most cases, however you did not install Multisite correctly. I know because you deleted a line 😉

    ‘define(‘WP_ALLOW_MULTISITE’, true);’ is missing.

    Hey Mika,

    those hash passwords are actually misguided. Thank you for helping me to delete those though. 🙂

    I realised that i had removed that line when I pasted

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'facekitt.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Have since added the

    'define('WP_ALLOW_MULTISITE', true);'

    back to it’s place. but it’s still not working

    Any idea where can went wrong besides this? on another forum post it says something about removing, $base = ‘/’;
    I have tried this method and it did not work either.

    :(( the double chin is out! – bad joke!

    Please try to use ‘code’ and not ‘b-quote’ when quoting code 😉 Makes it easier to read.

    The hashes aren’t misguided, you need to change those too if the ones you posted were your real ones.

    The line should be define('WP_ALLOW_MULTISITE', true); (no extra quotes, that was a bad c/p from my end.

    /* That's all, stop editing! Happy blogging. */
    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'facekitt.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );


    It should be above the stop editing thing, but… Yes, that should work.

    http://asia.facekitt.com/ gives me not a 404 but a 500. Same as http://asdasdsa.facekitt.com/ (which shouldn’t exist)

    Did you set up wildcard subdomains on your server?

    I didn’t set up any. should i?

    i read this article an set up a mirror sub domain. it worked.



    Yes, you have to both create the site (which tells WP what do to) and add the subdomain to your server.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Can't create new sites on network’ is closed to new replies.