Support » Plugin: The Events Calendar » Can’t create new post with plugin activated

  • Resolved skyavenuepd

    (@skyavenuepd)


    I’ve been using your plugin for a long time and found it excellent – until this week.
    With an update to WP 5 (now 5.0.2) and using the latest Divi theme and the plugin activated, I cannot create or edit posts – I just get a blank white screen.

    When I deactivate the Events Calendar plugin, the edit/create post function works again as normal.
    Can you please help fix this.
    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Jeremy

    (@jeremy80)

    Hi @skyavenuepd!

    It’s possible there is a conflict with another plugin. If you only activate The Events Calendar and use Divi as a theme, do you still have a blank white screen? If not, could you update your plugins one by one until you come across the one which is in conflict with The Events Calendar? Please read carefully our documentation about testing for conflicts before doing anything.

    Let us know how it goes 🙂

    Cheers,
    Jeremy

    Hi @jeremy,

    Thanks for replying and for the link to testing for conflicts.
    It seems as though Event Calendar is conflicting with 2 other plugins (Bulletproof Security and Ninja Forms).
    On its own, Event Calendar works with Divi (only with the above plugins deactivated).
    When I deactivate Event Calendar with either of these other two activated, the problem goes away.

    Not sure where to go from here except for looking for alternative plugins which don’t cause conflict?
    Any help appreciated.

    I believe the problem is that you are exceeding your maximum allotted PHP memory limit. I just tested the Events Calendar with BulletProof Security and did not see a blank/white page when creating or editing Posts or Pages. The Events Calendar uses 6MB of PHP memory (idling) and is 50MB in size unzipped (files/folders). So if you are close to reaching your PHP memory limit and you go over your PHP memory limit when activating any other plugins then you will typically see a blank/white page. Go to the BPS System Info page and check your > PHP Actual Configuration Memory Limit. At bare minimum you should have 128M PHP memory. 256M is the optimum PHP memory limit. You can also check your PHP error log in your web host control panel for php memory limit errors. You can also use WP_DEBUG in your wp-config.php file to display PHP errors > https://codex.wordpress.org/WP_DEBUG

    • This reply was modified 4 months, 2 weeks ago by  AITpro.
    • This reply was modified 4 months, 2 weeks ago by  AITpro.
    • This reply was modified 4 months, 2 weeks ago by  AITpro.

    Hi @aitpro,

    Thanks for taking a look and giving some suggestions!
    I checked the PHP Actual Configuration Memory Limit, which is 256M.
    I couldn’t see any PHP memory limits in the error log.
    The site has worked fine up until a few days ago (I have auto updates for WP and BPS set, so it just seems to have changed after recent updates).

    I temporarily tried another calendar plugin and the problem went away.
    I’d rather stick with ‘Event Calendar’, but don’t know how to resolve the issue.

    Hmm then maybe there is another factor involved such as a 3 way combo problem or something else like a particular setting in the events calendar plugin. Are you using a caching plugin or proxy that is caching your backend wp-admin area? Try adding the WP_DEBUG constant in your wp-config.php file and then try to create a new Post. You may or may not see any error messages, but it is worth a try. After you are done testing change the values to false instead of true.

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', true);

    Hey,

    thanks for the reply. i’m using a completly clean installation without any plugins. so there is no caching and the debug log is empty.

    a) is there maybe another loop for the event calendar, which is called the “the_content()” function?

    b) how do i get the current event ID when i’m on a single event page? i’m always getting a “0”, wether i’m on the overview or on the single event page. i understand, that there is no “physical page” for the overview (like an archive), but i should get an id on the single page, right?

    Hi @aitpro,

    Thanks again for taking the time to look at the issue.
    When I logged in this morning, the issue has gone away.
    I haven’t made any changes since I posted the original fault, so I do not know what caused the previous issue. Perhaps you were right and it was a temporary php memory issue and is now resolved (hopefully).

    Thanks again.

    Might have been some kind of temporary host server problem or maybe whatever Opcache/sever-side cache your host server uses was messing up temporarily.

    Issue resolved

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.