Support » Fixing WordPress » Can’t create category

  • Resolved clpo13

    (@clpo13)


    Recently, I upgraded from 2.0.7 to 2.1. When I was using 2.0.7, I could create categories but trying to delete them produced an error in WP which told me I didn’t have permission to do that. I was never able to solve that problem.

    Now that I’ve upgraded to 2.1, I can neither delete nor create categories. Attempting to do both results in WP telling me I don’t have permission. What could be going wrong here? I’m the admin of my blog and I’m fairly sure all my file permissions are set correctly. Why can’t I add new categories?

Viewing 15 replies - 1 through 15 (of 31 total)
  • gaboinked

    (@gaboinked)

    I installed a clean version of 2.1 and can’t create post categories from either the post itself, or from the Manage Categories options. It does not give me any error messages or notices.

    I am affraid that I may have jumped into the new version a bit too soon.

    Is there an explanation for this in the case I have configured something ncorrectly?

    Aniket

    (@aniket)

    same here too i cannot create categories ,their is a work around download a plugin called category manger

    clmyers

    (@clmyers)

    No solution, just saying I’m having the same problem.

    deko

    (@deko)

    I had the same problem. I’m not sure why, but after I replaced all the core files with a newly downloaded batch, it began working.

    This was not a re-install – I simply uploaded all new core files to my install directory on the server.

    neofufalum

    (@neofufalum)

    I had the same problem. I installed version 2.1.

    neofufalum

    (@neofufalum)

    Which ones are the core files?

    deko

    (@deko)

    Core files are everything except what’s in your wp-content folder (and your wp-config.php file)

    After I installed 2.1, the first problem I had was not being able to add categories.

    So I re-downloaded everything and re-uploaded all core files to my server… worked for me.

    spacerog

    (@spacerog)

    I have the same problem. Not only did I download new copies of the files but I deleted all my old files and deleted my orginal database and started all over. Still can not create catagories. Can’t create users from the Admin interface either.

    – SR

    spacerog

    (@spacerog)

    I installed the Manage Catagories plugin which seems to have solved my problem. My default install of WordPress would not allow me to create catagories or new users. I installed the plugin, created a catagory, then deactived the plugin and I could then create catagories and users the correct way. Yeah! thanks.

    Catagory manage can be found here
    http://wordpress.org/support/topic/94406?replies=10#post-514290

    – SR

    ssouci

    (@ssouci)

    Cannot believe there is no solution for this… adding a new category seems to be at the very heart of WP functionality!

    Feb-11-2007 I just did fresh install of WP 2.1 (via Fantastico at Lunarpages hosting). Install went well and quickly. Was able to access admin panel and make a few test changes, BUT cannot create a new category. When I try to to so by entering category name, etc. and then hitting submit, NOTHING happens (no error, no new category). Checking the published site confirms no new category created.

    I tried full WP delete and another fresh install, but exact same problem.

    Installing a plugin for this as suggested above seems crazy! This is a basic WP function.

    Anyone have an explanation or fix?

    Thanks!

    ssouci

    (@ssouci)

    further to my post above…

    – I’m using Win XP, SP2
    – have tried using both MSIE 6 and Firefox
    – I’m logged in as the administrator, and have also tried logging in as an editor
    – have alternatively tried to create a new category from the “make a new post” screen

    in each case, I have the same problem > I simply can’t create any new categories, no matter what

    HELP! my launch onto WordPress has been a disaster so far

    PS: I ran an earlier version of WP just 2 months ago to test it out (using exact same method via Fantastico) and it worked just fine

    thx!

    clpo13

    (@clpo13)

    I tried the solution spacerog posted above and now I can add, delete, and edit categories. Still no word on why I couldn’t in the first place, but at least I have a workaround.

    Bartles

    (@bartles)

    I’ve been having the same issues. I couldn’t create categories (among other things) and could not ever logout (it would always take me to the dashboard page). I could always tell when it was acting up since when I would attempt to navigate away from a given page a little warning box would come up (ie “are you SURE you want to leave this page yada yada”)

    Somehow I figured out something that works for me. I realized that I was logging in via domain.com/wp-login.php. I started logging in via domain.com/wp-admin/ instead and everything works perfectly. No clue why this might help, but hopefully this works for others as well.

    Cheers
    B.

    Same problem here – can’t create new categories!!!

    (going to try and put them in the database myself, but can’t help feel this isn’t the correct solution!)

    I have this problem also after the upgrade. I am using FF 1.5.03.

    My workaround solution is to disable Java and JavaScript for the time that I am creating and editing categories, then turn them back on once I’m finished working with categories.

    In FF: Tools –> Options –> Content –> Enable Java/Enable Javascript.

    HTH for now.

    Mojo

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Can’t create category’ is closed to new replies.