Support » Fixing WordPress » Can’t create a wordpress.com account!

  • Resolved needforname

    (@needforname)


    How could something this simple not work!

    I’m all sorts of confused here. In order to retrieve the API Key, it tells me to create an account at wordpress.com. So i go to wordpress.com and attempt to create an account. Every time i enter in my info and hit next, the page refreshes with empty fields and doesn’t tell me why? It just won’t let me create an account, and with absolutely no explaination. I’ve tried numerous usernames and passwords and made sure I was doing what it told.

    What the heck is going on here? I’ve never been so frustrated over something that should not be complex at all. Yes I have cleared my cookies, and yes I have cleared my cache, and yes I have “accept cookies” turned on. I have tried this in both Safari and Firefox. Driving me mad. Can anyone help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Have a look at http://support.wordpress.com/contact/

    (we can’t help you with .COM issues here. We’re just the .org folks)

    thanks chris…i have a .org site, so I just decided to post in here. My bad.

    Well, it appears that wordpress.com doesn’t even have a forum (as far as i can see), so I guess i have to wait days for a response from customer service. I can’t believe it won’t even let me create an account. I’ve NEVER had a problem like this with any other website.

    Support
    http://support.wordpress.com/

    Forums
    http://en.forums.wordpress.com/

    This post was brought to you by the letter N and google search… 🙂 …

    Thanks. I know how to do a google search, but i’ve never seen a website that didn’t show the forum as a main category or atleast sub-category. Pretty strange.

    Well, since it won’t let me create a wordpress.com account, how can i post my question in the wordpress.com forum? To ad a post, i need to be registered. And yes i did search for an answer.

    My girlfriend can’t get it past the first page of the sign up process either (on a different computer, also with the cookies/cache deleted). This is the stupidest thing I’ve ever seen. Call me a newbie all ya want, but this is rediculous.

    Well it appears that I wasn’t loosing my mind after all. WordPress.com contacted me with this:

    “I’m so sorry for the inconvenience – earlier today we unwittingly introduced some code with temporarily broke the sign-up process. This has all been fixed now and you should be able to sign-up for an account without any problems.”

    Sorry about that,

    Hanni

    —Now it works just fine. Just wish I didn’t have to waste 2 hour last night trying to figure this out. Oh well.

    Thanks for the follow-up on that, good to know it was a glitch. 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can’t create a wordpress.com account!’ is closed to new replies.