Support » Plugin: Pods - Custom Content Types and Fields » Can`t create a new POD in WordPress 5.3 (de_DE)

  • Hello,
    if I install a blank WordPress 5.3 with german language (de_DE) with pods, I can`t create a new pod. I will be linked to the page “Sorry, you are not allowed to access this page.“. Impossbile to do anything, also taxonomies etc, also with new users etc.

    But now I found out, when I install the english version with WordPress 5.2 it works properly. It will NOT work with the locale de_DE of 5.2 or lower, only with < 5.3.

    When I update WordPress to 5.3 no changes in existing pods will be saved. Only after a downgrade to 5.2 it will work again poperly.

    Is this a known error? I want to update soon as possible, but it seems pods is not compatible with the 5.3 version of WordPress now.

    Usually I use WP-CLI to install, but it also happens when I install it manually per FTP, no difference.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jory Hogeveen

    (@keraweb)

    Hello @tobeworks

    I’ve tried to reproduce your issue with the de_DE installation from de.wordpress.org and it all works fine here.
    It seems very strange the the default installation package would work fine (en_US) and de_DE doesn’t. Both (should) use the same code.

    In any case. I cannot reproduce. Can you reproduce this on a clean WordPress installation with ONLY pods installed?
    Let me know!

    Cheers, Jory

    Hello Jory,
    yes. I tried this around 30 times with fresh installations in many variations.

    I usually use my installer script with WP CLI (but I also tried with a normal download from wordpresss.org)

    I also up- und downgrade via WP-CLI and the <= 5.2 works and the 5.3 not.

    my installer in that case:

    #!/bin/bash
    
    dbname='wp_test';
    dbuser='wp_user';
    dbpass='XXX';
    url='wordpress.tobeworks.de';
    admin='Test';
    admin_pw='aAmogPTWaDnw6eMhMsRK0(DQ';
    admin_email='test@tobeworks.de';
    
    wp core download --locale=de_DE --version=5.2;
    wp config create --dbname=$dbname --dbuser=$dbuser --dbpass=$dbpass  --locale=de_DE;
    wp core install --url=$url --title=Wordpress --admin_user=$admin --admin_password=$admin_pw --admin_email=$admin_email;
    
    wp plugin install pods --activate;
    
    exit;

    The installed wordpress is a fresh 5.2 with working PODs and some test pods and test taxonomies. If you make a update to 5.3 (you can login with the Test-user) it won`t be possible to edit the pods. After a downgrade to < 5.3 it will be possible to edit again. 😉

    • This reply was modified 1 month, 1 week ago by tobeworks. Reason: version in script
    Plugin Author Jory Hogeveen

    (@keraweb)

    Hello @tobeworks
    I checked your testing server and it looked (and worked) fine to me on WP 5.3.
    While I have no idea what is causing this issue for you it’s unlikely related to Pods.
    Cheers, Jory

    Hello Jory,
    I just tried this in a new browser (Brave) and recorded it, there is something which doesn`t work properly in 5.3:

    If I add a new POD, there is a message called “pod not found”. This pod is also not in the list, but seen on the left adminbar. If I add after that a new one, the one before isn`t in the adminbar anymore and the message is shown again “pod not found”. It is not possible for me to add new pods in 5.3.

    I made a small screencast, where you can see whats happening (tested in Firefox, Brave and Chrome)
    https://www.loom.com/share/802d29d7dac04c44843c63a9c4208920

    Ok, I think, that`s not a bug about pods, I found out, there is a strange thing with the timing and the post_status of ANY Posttype in this WP 5.3 The content will be displayed hours later after creation.

    The missing pods suddenly displyed after a couple of hours. Nerver seen something like this before.

    So, It is NOT about pods, there is something other wrong with PHP, PHP cache, oder somthing elase I already don`t know.

    Sorry for your time and thank you.

    • This reply was modified 1 month, 1 week ago by tobeworks.
    • This reply was modified 1 month, 1 week ago by tobeworks.
    • This reply was modified 1 month, 1 week ago by tobeworks.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.