Support » Fixing WordPress » Cant Create a New Page

  • I can create an About me page that works fine but when ever I try to create any other page it says it gets saved but when you try to view it its a 404 error.

    Any suggestions??

Viewing 14 replies - 1 through 14 (of 14 total)
  • Using_Permalinks – it should be there.

    doesnt seem to work. I can save a page but when ever I try to view the page i get a 404 error. and the page doesnt show up in the navigation bar.
    After i created the page i updated my permalinks and it says it was updated successfully but still get the same issue.

    here is how my .htaccess looks

    <?php
    // This is an example of a very simple template
    echo ‘ ‘;
    require_once(‘./wp-blog-header.php’);
    $wp_rewrite->use_verbose_rules = true;
    echo $wp_rewrite->mod_rewrite_rules(); ?>

    what am i doing wrong?

    When you save the Page your htacess must be writable. Not after.

    I have never seen a Page template like that 🙁

    Really? great lol

    ok actually i just noticed that this is just a htacess.php
    not an actual .htacess which doesnt seem to be anywhere in my root. would it be somewhere else like in wp-admin or anything or should I just create the .htacess and drop it in the root?

    is there a standard .htacess everyone uses or is it
    “theme specific”

    I created a .htaccess and loaded it with this code

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    is that all that is needed? Also i keep reading that the permalink section should say if your htaccess file is not writable or if it is.

    when i update the permalinks it just said updated ok.

    no pages are still being created though

    Basically, all the htaccess files look the same.

    I don’t get the “Pages are not created” part. Isn’t this a Page: http://www.anythingbutcoffee.com/laser-hair-removal/

    sorry yea that is a page on my personal blog
    Im talking about the blog for my work, http://blog.ienhance.com

    looks like our server is that IIS thing, so im reading that might be what is causing the issue? but the blog at work has an “about” page that works just fine but cant create a new one.

    If it is a IIS (win server) then the htaccess is completely useless. On the other hand on IIS server you could not have permalinks like this:
    http://blog.ienhance.com/category/facial-injectables/

    So, now I am confused. To be honest, I reject any WP job offer if they want to host it on IIS servers, so I don’t know anything about them, except that they never work as you need…

    yeah its all messed up lol. thanks though. ill look again tomorrow.

    This problem is annoying me as well. There’s no answers as of yet in the support forums, and nothing I have done to my .htaccess, permalinks, or file structure have solved anything yet.

    I’m on a FreeBSD server, MySQL 12.22, PHP 4.4.1 and all my permissions are set liberally to make this thing run well.

    I upgraded to 2.3.1 and the problem still isn’t resolved.

    MatthewEbel – If you are convinced this is a bug, search the WordPress trac and if necessary, report the bug there.

    http://trac.wordpress.org
    Reporting_Bugs

    Please note you can use your forum login/password at trac.

    @MichaelH-

    Thanks for the reply. I’m only thinking it’s a bug because none of my troubleshooting has worked, AND nobody else seems to have a resolution for this either. The nature of the problem would suggest a database problem, but I visually inspected the entries associated with the missing pages and they seem perfectly formed.

    Any suggestions?

    Matthew, when you report the problem, make sure you include your server, php, mysql versions as well as all the steps you have taken to resolve the problem.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Cant Create a New Page’ is closed to new replies.