Support » Plugin: Bitcoin and Altcoin Wallets » Cant connect with My Own BTC full core node server

  • Resolved muslimcodeid

    (@muslimcodeid)


    Hi Support,

    I have installed this plugin i would like to connect with my BTC full core node server
    I follow the tutorial from this videos https://www.youtube.com/watch?v=_dbkKHhEzRQ always got this error
    Not responding: Dashed_Slug_Wallets_Coin_Adapter_RPC->get_balance() failed with status=”0″ and error=”Failed to connect to 161.97.174.243 port 8332: Connection refused”

    This is my netstat result

    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 127.0.0.1:8332          0.0.0.0:*               LISTEN      12623/bitcoind
    tcp        0      0 0.0.0.0:8333            0.0.0.0:*               LISTEN      12623/bitcoind
    tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      374/systemd-resolve
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      419/sshd: /usr/sbin
    tcp        0      0 161.97.174.243:54500    24.233.245.188:8333     ESTABLISHED 12623/bitcoind
    tcp        0      0 161.97.174.243:8333     121.35.101.182:12811    ESTABLISHED 12623/bitcoind
    tcp   4861275      0 161.97.174.243:47072    86.0.33.192:8333        ESTABLISHED 12623/bitcoind
    tcp        0      0 161.97.174.243:8333     114.115.190.36:6569     ESTABLISHED 12623/bitcoind
    tcp        0      0 161.97.174.243:8333     116.20.126.206:13414    ESTABLISHED 12623/bitcoind
    tcp        0      0 161.97.174.243:8333     23.92.36.3:34790        ESTABLISHED 12623/bitcoind
    tcp   4126016      0 161.97.174.243:36486    31.47.202.112:8333      ESTABLISHED 12623/bitcoind
    tcp        0    272 161.97.174.243:22       172.105.122.7:50344     ESTABLISHED 11287/sshd: root@pt
    tcp   4011177      0 161.97.174.243:43944    174.93.15.90:8333       ESTABLISHED 12623/bitcoind
    tcp        0      0 161.97.174.243:8333     209.222.252.193:21815   ESTABLISHED 12623/bitcoind
    tcp   818200      0 161.97.174.243:40976    3.1.201.76:8333         ESTABLISHED 12623/bitcoind
    tcp        0      0 161.97.174.243:52738    104.237.129.105:8333    ESTABLISHED 12623/bitcoind
    tcp   751512      0 161.97.174.243:41888    64.225.22.38:8333       ESTABLISHED 12623/bitcoind
    tcp        0      0 161.97.174.243:8333     23.92.36.3:30323        ESTABLISHED 12623/bitcoind
    tcp   4691737      0 161.97.174.243:37788    178.193.226.120:8333    ESTABLISHED 12623/bitcoind
    tcp   2902337      0 161.97.174.243:40132    84.15.106.3:8333        ESTABLISHED 12623/bitcoind
    tcp   3212833      0 161.97.174.243:48074    80.0.141.86:8333        ESTABLISHED 12623/bitcoind
    tcp6       0      0 :::8333                 :::*                    LISTEN      12623/bitcoind
    tcp6       0      0 :::22                   :::*                    LISTEN      419/sshd: /usr/sbin

    and this is my bitcoin.conf file

    https://pastebin.com/cATML8yV

    Need your assistance to check

    Thanks in advance

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author dashed-slug.net

    (@dashedslug)

    Hello,

    I can’t check your config file since it was removed. However here’s a few pointers:

    1. If you can’t connect, then the plugin will recommend a few config entries in the admin screens. It’s a good idea to start from there.

    2. Since the video was created, bitcoin core now requires the rpcbind config entry to open up ports. Use rpcbind to specify the public IP of the machine running the wallet. This should be the same IP that you set in your Bitcoin adapter settings.

    3. If IPv4 doesn’t work, try IPv6 addresses.

    4. Connection refused means that the WordPress machine could not connect to your wallet’s RPC port. This could be for any number of reasons. Check the firewalls between the two machines. If necessary, talk to your hosting providers about it. You basically want to allow incoming TCP connections to the wallet machine on port 8332.

    Hope this helps. Please let me know if you continue facing difficulties after trying the above.

    with regards,
    Alex

    Thread Starter muslimcodeid

    (@muslimcodeid)

    Hi Support,

    Thanks for your reply.

    What you explained above i totally agree and its same like my analysis.
    I already make sure that from my webhosting,outgoing connection to 8332 is open but now i am still waiting an answer from my vps (btc core server) porivder to check whether they block this port or not,because from the vps firewall itself i already allow or open the port 8332(8333 also).

    here my bitcoin.conf,look like

    server=1
    rpcallowip=127.0.0.1/8
    rpcallowip=198.54.114.yyy/24
    rpcport=8332
    rpcbind=127.0.0.1
    rpcbind=198.54.114.yyy
    walletnotify=curl -s https://cryptominer-shop.com/wallets/api3/notify/BTC/wallet/%s >/dev/null
    blocknotify=curl -s https://cryptominer-shop.com/wallets/api3/notify/BTC/block/%s >/dev/null
    rpcauth=rpcuser:50c2cf373adbef15efe6eddf7a8b0f89$a1c5dd66dad3515ac074c5599da93db9ac19cfa0cdf40a665ea286547cd92126

    there is one thing thats make me confuse,if you can see above(netstat result)
    there is port 8332 and 8333 open,but if i put 8332 as rpcport on my bitcoin.conf, i able to telnet port 8333 but not 8332, but if i put rpcport:8333 i am not able to ping both of the port

    any advice

    Thanks in advance

    Plugin Author dashed-slug.net

    (@dashedslug)

    First of all, you cannot set rpcport=8333 because that’s the port that Bitcoin uses by default for its P2P communication. Better stick to the default 8332 for the RPC API port.

    1. Most likely your VPS blocks all incoming ports except for a few whitelisted ones (HTTP, HTTPS, ssh). So it’s very likely that this is the issue. Your hosting provider will be able to let you know and possibly enter a rule into their firewall for you.

    2. Another potential problem that I see is that you’ve allowed incoming connections from 198.54.114. You did not provide the entire IP, but I’m not sure if this is in a public IP range. I could be wrong about this, but if this IP is in a reserved range, this is not going to work. Using the rpcallowip config, you are saying to your wallet that you want to allow connections from this IP. If you try to connect from a machine in your local network, when your wallet filters incoming IPs, it will see an incoming connection from your local network as coming from the public IP of your router, not the local IP. If you’re sure that this is a valid public IP, then this is not the root cause of the problem.

    3. Finally, remember to restart your wallet after any changes to your .conf file.

    If you cannot telnet from your WordPress machine to your wallet machine’s RPC port, then that has nothing to do with the plugin. This is likely a networking issue, so wait until your host replies to you about firewalls. You could also try asking for bitcoin core support. A good place to ask questions on how bitcoin core works is https://bitcoin.stackexchange.com/

    Let me know if the above is not clear or if you have more questions about this.

    with regards

    Plugin Author dashed-slug.net

    (@dashedslug)

    Also, since you have pasted your rpcauth= line here, don’t forget to change your password once you get this working.

    Thread Starter muslimcodeid

    (@muslimcodeid)

    Hi Support,

    Finally I managed to solve this issue.
    with change the rcpbind ip with my btc core node server IP.
    fyi,i also already change the rpc password

    Thanks for your help in advance

    Plugin Author dashed-slug.net

    (@dashedslug)

    Glad to hear it! Thank you for taking the time to report back.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cant connect with My Own BTC full core node server’ is closed to new replies.