Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Can’t connect to WordPress.com

  • Resolved SciFiKriss

    (@scifikriss)


    Hi guys

    Having problems connecting… checked with my hoster and they are not blocking it.

    They came back with error…

    Nov 6 13:13:23 l7lb20.ptl.stackcp.net haproxy[15846]: 192.0.84.134:61480 [06/Nov/2020:13:13:21.143] proxyfroml4~ standard_bot/web36.hosting.stackcp.net 0/0/17/2724/2741 200 1198 – – —- 211/211/26/2/0 0/0 {nikmania.me.uk|US|2635||Jetpack by WordPress.com|standard} “POST /xmlrpc.php?for=jetpack&rand=746462403 HTTP/1.1”

    I try to log into .com and all I get is a quick blink of the logged in screen then it collapses.

    Thanks in advance

    Kriss ūüôā

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    We’re being blocked from accessing https://nikmania.me.uk/xmlrpc.php which Jetpack requires to function.

    Unfortunately, blocking XML-RPC is not a great solution for fighting security risks. It’s akin to selling your car because you don’t want it to be stolen.

    Your site’s XML-RPC file is kind of like a communication gateway to your site. Jetpack, the WordPress Mobile Apps, and other plugins and services will use this file to communicate to your site. If this is blocked, you will have other issues pop-up down the road for the same reasons.

    If you are using any security plugins, please try connecting with those temporarily deactivated. If you don’t have any, or if that didn’t work, I would suggest contacting your hosting provider and asking them to unblock your site’s XML-RPC. The most popular hosting providers out there have managed to find other ways to protect their servers without having to hinder your site and your ability to use services with your WordPress site.

    As you can see from above they have already checked and they are not blocking it and this is the error they are getting.

    They did do another check for you…

    -bash-4.1$ curl -A ‘Jetpack by WordPress.com’ -d ‘<methodCall><methodName>demo.sayHello</methodName></methodCall>’ https://nikmania.me.uk/xmlrpc.php
    <?xml version=”1.0″ encoding=”UTF-8″?>
    <methodResponse>
    <params>
    <param>
    <value>
    <string>Hello!</string>
    </value>
    </param>
    </params>
    </methodResponse>

    They are not blocking it…

    Plugin Contributor Dan

    (@drawmyface)

    Just visiting https://nikmania.me.uk/xmlrpc.php in a browser gives a 403 error ‘Request forbidden by administrative rules.’

    This file must return the following message:

    XML-RPC server accepts POST requests only.

    You can see a working example here:

    https://jetpack.com/xmlrpc.php

    Since your site returns a 403¬†error¬†for this page, I would recommend that you check if you use any security plugins that may block access to this file. If so, could you try to disable them? You might also want to check your site’s .htaccess file for any rules that might be blocking access to the¬†xmlrpc.php file.

    If you don’t find any plugin that may block access to the file on your site, I would recommend that you get in touch with your host again.

    Once we are able to access your site’s¬†xmlrpc.php file, you should be able to connect Jetpack to¬†https://wordpress.com.

    I have passed it back to my hoster as I turned off all the plugins and still couldn’t get in…

    This is the reply from my hoster…

    XMLRPC is a key attack target and denial of service vector against any WordPress site, so we filter traffic towards it as part of our Web Application Firewall.

    Known “trusted” applications and networks are permitted access, but unknown sources and especially any web browser-based requests ( https://nikmania.me.uk/xmlrpc.php ) to xmlrpc.php are blocked for security reasons. That would be why you are receiving the error when trying to access the link directly. You will need to make a request to the XMLRPC using the jetpack. As aforementioned by my college, this would give a 200 server response. By default, we allow XMLRPC connections for jetpack. That wouldn’t be the cause of the issue you are currently experiencing here.

    Plugin Contributor Ryan C.

    (@ryancowles)

    Thanks for the update! I’ve had another look at your site’s connection and see a different error now. As a next step, I’d like to try clearing Jetpack’s settings on your site and installing a fresh copy of the plugin.

    Could you please try uninstalling and reinstalling the Jetpack plugin from your Dashboard? To do so, follow these steps:

    1. Navigate to Plugins > Installed Plugins
    2. Deactivate Jetpack
    3. Click the “Delete” link under Jetpack and follow the prompts to confirm
    4. Install the Jetpack plugin once again
    5. Connect Jetpack

    Following these steps will clear out existing settings, and allow you to attempt a fresh connection. Please let us know when you’ve done the above, and we’ll check your connection once again from our end!

    • This reply was modified 2 months, 2 weeks ago by Ryan C..

    It looks like it has worked… I did have to try it 3 times though…then went back to the plugin screen and thought let’s try it from there and it connected straight in so no idea what happened.

    Thanks

    Plugin Contributor Dan

    (@drawmyface)

    Glad to hear it worked eventually!

    Let us know if you have any more issues.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.