Support » Plugin: Jetpack by » Can't connect to wordpress after moving site

  • Resolved etoiline


    I have Jetpack network activated for my site It’s also activated on another domain I administer (, which runs off the same install as my main site (multisite with domain mapping). I used to have a separate install of WP running a different site,, with its own instance of Jetpack. I was finally able to port to my main site install, but when I try to connect Jetpack to WordPress for this site, it gives an error:
    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32700
    Try connecting again. Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL. Please check to make sure is working properly. It should show ‘XML‑RPC server accepts POST requests only.’ on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.

    I guess Jetpack is still trying to connect to its old install location in /words, but of course that folder doesn’t actually exist anymore since I moved the site into my main install. I’m wondering if there is a way to fix that so the one instance of Jetpack can connect all three sites and maybe get my old stats back for /words.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeremy Herve


    I had a look at your site, and it seems to be properly connected to now. Your Jetpack settings are using the new URL, and everything seems to be working properly.

    Have you managed to solve the issue by yourself?

    Unfortunately that’s not the case. Jetpack worked fine on and, and after a reinstall of the plugin, still works fine and can connect to with both of those sites. However, I still cannot connect for, which as mentioned before used to be running on a separate instance of WP (using the same URL–WP was running out of a subdirectory called /words, but I have since changed that folder name after I imported all posts to my main multisite and got rid of the other instance of WP). When I try to connect Jetpack to in the dashboard for /words, it gives the same error as above (again, this is a fresh install of Jetpack).

    So two of my sites are connected just fine, but the third site (/words) is not. Is there a way I can redirect the /words site to the actual location of xmlrpc ( instead of which doesn’t exist anymore)?


    Plugin Author Jeremy Herve


    I’m sorry, I’m not sure I understand. and work just fine, but you’d like to use Jetpack on a third site,, is that correct?

    I can’t seem to access at the moment, so that might explain why you can’t connect Jetpack to on that site.

    Could you make sure that the site is up and publicly accessible? If that’s the case and you still get an error when trying to connect Jetpack to, could you copy the URL of the Jetpack menu as it appears when you try to connect to
    Could you also go to Settings > General, and let me know what your WordPress URL and Site URL are?


    I think I might have figured it out. The site was down because of an empty directory folder that I must have forgotten to delete, so that was an easy fix, but when I looked into the site URL page (thank you for pointing me in that direction), I saw that I had archived the old /words site (the one that was running off a separate install of WP). It was still listed as /words in the site directory field, and I changed the directory name to /words2, and then tried connecting Jetpack. I wonder if the plugin was trying to connect to the archived site instead of the new one, and running into problems because of the same name.

    Thanks for showing me the right place to look. I figured it had something to do with the new site having the same name as the old, but I forgot about the archiving. Glad this turned out to be an easy fix.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can't connect to wordpress after moving site’ is closed to new replies.