Support » Plugin: Wordfence Security - Firewall & Malware Scan » Can’t connect to WordFence central

  • Resolved imokweb

    (@imokweb)


    Hello

    I am using wordfence central for several sites, but for some reason I can’t connnect on this one. I found a thread that was similar to this one and tried what was written there (added an excepntion in cloudflare, updated everything, disabled all the plugins and left just wordfence as an active plugin and I still get the meassage that “We’ve detected CloudFlare blocking our requests to your site. For help on resolving this issue, see our troubleshooting connection issues article here.”
    This is the rule added to cloudflare http://prntscr.com/u6u3wm
    Also did a scan and everything seems to be ok.
    I can’t figure out what the issue can be.
    Could you help me out figuring this one out?:)

    thanks

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support WFAdam

    (@wfadam)

    Hello @imokweb and thanks for reaching out to us!

    If you open WF Central and open the Connection Issues tab, are you seeing the site you are trying to add there? If you are, remove it from this list.

    On the site in question, navigate to Tools > Diagnostics > Other Tests > Clear all Wordfence Central connection data. Go ahead and clear the data.

    Now go back and try to re-add it to WF Central.

    I have also seen Cloudflare take a while to populate the rules correctly on their end. Depending on when you added the rule, I would give it some time before it starts working as well.

    Let me know if this was helpful!

    Thanks!

    Thread Starter imokweb

    (@imokweb)

    Hi @wfadam

    Thank you for your support.

    In Wordfence Central – we do not have this project listed in Connection Issues. We just can not add to the list.

    I can not see any Clear all Wordfence Central connection data in Tools > Diagnostics > Other Tests – so I can not clear it at all.
    What other options do we have?

    It will help you, if we will give our credentials to the site and to the Wordfence Central?

    Thank you

    Plugin Support WFAdam

    (@wfadam)

    Hello again @imokweb

    If you cannot see the Tools > Diagnostics > Other Tests > Clear all Wordfence Central connection data, then you may need to update your Wordfence as it was part of our latest release. Once you update and run this, try to connect back to Wordfence Central.

    https://prnt.sc/u8xx5b for reference if you need it.

    Let me know if this helps!

    Thanks!

    Thread Starter imokweb

    (@imokweb)

    Hi @wfadam

    Hmm,
    I made the followings, but nothing changed:
    – updated the Wordfence plugin – DONE,
    – Clear Connection Data – DONE,
    – cleared the Cloudflare – DONE
    – checked the Firewall Rules for the Wordfence IP address – added, DONE – https://prnt.sc/u91urm
    – tried to add the URL to Wordfence Central again, but it still gives the same failure: https://prnt.sc/u91v7v

    What am I missing?
    Oh, and it was written that after the clearing, all data have been cleared from the Database – related to the Wordfence.
    We have the same issue, with some other projects.

    Thank you.

    Plugin Support WFAdam

    (@wfadam)

    Hello again @imokweb

    Can you send a diagnostic report to wftest @ wordfence . com? You can find the link to do so at the top of the Wordfence Tools > Diagnostics page. Then click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    Let me know once you’ve sent it!

    Thanks again!

    Thread Starter imokweb

    (@imokweb)

    Hi @wfadam,
    I did, I sent a diagnostic report to the asked email with username: imokweb.
    Best regards

    Plugin Support WFAdam

    (@wfadam)

    Thanks for sending the report @imokweb

    This seems like it could be a plugin/theme conflict.

    Could you try disabling your plugins, with the exception of Wordfence, then retry to connect the site? First, check your Connection Issues tab in Wordfence Central and clear out any issues in there.

    Let me know if this helps!

    Thanks!

    Thread Starter imokweb

    (@imokweb)

    Hi @wfadam,
    I deactivated all the plugin – but not the Theme one – we use Enfold + Child Theme.
    And deleted all the sites from the Connection issue Tab.
    And it still gives the same problem.
    Tomorrow I will talk with my colleague and we will create a WP admin login for you, I hope that will be the best and if it will work, we can use the same settings for the other sites which are not running on our side.
    Does it make sense?

    Thank you.
    Best regards

    Plugin Support WFAdam

    (@wfadam)

    @imokweb it looks like your REST API is blocked for users that aren’t logged in. I just did some tests on my end.

    Note: Wordfence Central uses the WordPress REST API to communicate with the plugin. If you’ve disabled the REST API or set it to require authentication, you’ll need to enable it before connecting your site to Central.

    Not sure if its something you have set on your side or a plugin that is causing it, but if you enable the REST API, it will resolve your issue.

    Let me know if this helps!

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t connect to WordFence central’ is closed to new replies.