• ResolvedModerator Bet Hannon

    (@bethannon1)


    On a development site, I am trying to connect the WooCommerce Stripe Gateway to a Stripe account. The initial button opens the Stripe page to select the correct Stripe account, and once the connect button is clicked it seems to be processing with the notice that it would be redirecting back to the WooCommerce dashboard. BUT I only ever get redirected back to the “Get started with Stripe” page. No error messages.

    I’ve ruled out plugin & theme conflicts; the Stripe account connects ok to other plugins so I don’t think it’s a problem with the Stripe account.

    Knowing that there have been a lot of updates to WooCommerce and WordPress in the last couple of weeks – I tried rolling back all three in various combinations: WordPress core, WooCommerce and WooCommerce Stripe gateway. No luck.

    Suggestions for next step troubleshooting?

    Is there any option at all to manually connect?

    • This topic was modified 1 month, 2 weeks ago by Bet Hannon.
    • This topic was modified 1 month, 2 weeks ago by Bet Hannon.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support ckadenge (woo-hc)

    (@ckadenge)

    Hi there @bethannon1,

    I’m sorry to hear about the issue you’re experiencing with connecting the WooCommerce Stripe Gateway to your Stripe account.

    It seems like you’ve already tried a number of troubleshooting steps, which is great. However, if you’re still facing the same issue, here are a few more suggestions:

    1. Clearing your browser cache: Sometimes, cached data can interfere with the connection process. Try clearing your browser cache and cookies, then attempt to connect again.
    2. Check your site’s SSL: Stripe requires your site to have a valid SSL certificate for the connection to work. Please ensure your site’s SSL certificate is valid and up to date.
    3. Server Configuration: It’s possible that your server configuration might be blocking the connection. You may need to check with your hosting provider to ensure that there are no restrictions in place.

    Just to clarify, Stripe does not provide an option to manually connect your account due to security reasons.

    If the problem persists after trying these steps, please provide us with the system status report from WooCommerce > Status > Get system report > Copy for support, then paste it via https://gist.github.com/ and send the link here.

    Moderator Bet Hannon

    (@bethannon1)

    Yes, I left that out– I’ve cleared every cache, and even tried in multiple browsers and incognito windows.

    The site is a dev site, but it does have a valid SSL

    I’ve checked with the host and there are no issues with the server. AND, I was able to connect Gravity Forms to Stripe yesterday (which seems to use the same Stripe connecting process page).

    Other suggestions?

    Moderator Bet Hannon

    (@bethannon1)

    Ok, I poked at this a little more. I made a staging site of my dev site on a different server, which let me connect and then pushed the connection back to the dev site. Which would seem to indicate some issue with the server blocking the connection, but I have no idea what. But maybe this workaround will help someone else.

    Plugin Support omarfpg (woo-hc)

    (@omarfpg)

    Hi @bethannon1,

    Thank you for the heads up and for testing and reporting back to us that the issue is server related. I’d recommend checking with your hosting provider to learn more details about this.

    Cheers!
    -OP

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.