Can't connect to localhost (3 posts)

  1. CharlieBloxham
    Posted 2 years ago #


    I've downloaded wordpress and mamp, created a test database and changed the WP-config file in ht docs. I'm now trying to access localhost:8888/wp-admin/install.php to install wordpress but when I enter that address into the domain box the next page that appears is 'Chrome/Safari can't connect to the server'.

    What can I do to fix this?


    I'm following this video if it helps: http://www.youtube.com/watch?v=gP4E3KT12Zg

  2. CharlieBloxham
    Posted 2 years ago #

    I've just reset the ports in mamp to default and tried localhost:8889/wp-admin/install.php and it just downloads a file called install.php and doesn't load the wordpress installation site as it should with the browser. Any ideas what's going wrong and how I can fix it?


  3. 2ninerniner2
    Posted 2 years ago #

    Generally not a good idea to install any script (WP, Joomla!, Druapl, etc.) into the root of a local install; makes things "messy" :)

    Also not a "good idea" to mess with the default MAMP settings unless you absolutely know exactly what you are doing ... and why! :)

    - create a folder within htdocs and name it wp361 (for example)
    - extract the WP ZIP that you downloaded into this folder
    - there will be a wordpress folder there that has all the files/folders; move them all up one level to /wp361
    - create the new, empty database in phpMyAdmin (also name it wp361 for example)
    - run the WP install by going to:


    Assuming a default MAMP install, your info on the Create the configuration page is:

    Hostname: localhost:8889 <<NOTE: this is the port for the database server, NOT the web saerver (which is 8888)

    User: root

    Password: root

    Table Prefix: leave as-is ... why complicate it at this point? :)

Topic Closed

This topic has been closed to new replies.

About this Topic