Support » Fixing WordPress » Can't connect to FTP

  • I’ve just started using WordPress through an installer my web hosting company provides. They didn’t install the latest version 3.5.1, so now I need to that. The issue is that it won’t connect to my server ( I know I have the correct settings in there, I was able to connect through FileZilla). I have tried to do the manual installation, and read for hours about all the different ways to try it, but it just won’t work for me

    I have to think there is another way around this. There have to be so many people using WordPress that connect through some sort of installer and a manual update wouldn’t work for them.

    I have a shared server and I’ve read that could be the issue. Does anyone know of a way to connect automatically if you’re using a shared server?

    I appreciate so much if anyone can help me with this. WordPress is perfect for what I want to do, but I’m about ready to move on.

Viewing 15 replies - 1 through 15 (of 15 total)
  • when you are trying to update is it ask you for the ftp info?

    it should ask you for your ftp info

    Yes, it asks me for my FTP information and when I type the correct information in, it says it cannot connect. I know my FTP information is correct because I can log in through File Zilla.

    It is maybe a permissions related problem, have you set folders and files permissions correctly?

    http://codex.wordpress.org/Changing_File_Permissions

    Sorry, help me understand, how does this affect connecting through FTP?

    What I’m saying is that I’m putting the exact information I’m putting into File Zilla right into the WordPress automatic upgrade, connect through FTP fields and it’s saying it won’t connect.

    Ok sorry I misreaded, if it says it can’t connect then it’s probably not permissions.

    Is your webhost allow you to connect with FTPS (SSL)? if yes then use these info it should work.

    Here is the error I get:

    ERROR: There was an error connecting to the server, Please verify the settings are correct.

    I KNOW the settings are correct. I’ve connected through file Zilla and I just connected with my web browser as well.

    I’ve read multiple threads with people with this same issue, but it never seems to get resolved. I’m asking for a suggestion or resolution that does not include the manual installation. Again, I do have a shared server.

    Thank you for your help castordor!!

    Have you change the default FTP port (21) in your shared server?

    Again, have you tried to connect with SFTP?

    No, I use port 21.

    It does not give the option to use SFTP, only FTPS (SSL) and I have tried that as well.

    I guest you have cpanel access? Create a new FTP account in cpanel and try with these info.

    Good thought, but I already tried that and it did not work. Again, I tried it with File Zilla and was able to log in with the new credentials.

    I once had similar problem, instead of http://ftp.naijabambam.com I was using http://www.naijabambam.com

    estiner have you found a solution? It’s happening to me aswell right now.

    I had this problem too. When I used ‘localhost’ for the host name, it failed. I used ‘127.0.0.1’ and it worked. I can only guess that php doesn’t use /etc/hosts for name resolution.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can't connect to FTP’ is closed to new replies.