[resolved] Can't connect to Db with WordPress but I can with Adminer (4 posts)

  1. I'm trying to set up a new site on Netnation (I know, I know, shite host.. but that's where the client is. )

    They don't provide phpMyadmin, so i installed adminer, connected to the db and uploaded the db. Great

    Tried to connect to the db using the same credentials and that won't work.

    Why would that be? Seems strange to me.

  2. Sugar Apple
    Posted 4 years ago #

    in my past experience you need to check :
    1. database host url
    2. database name
    3. database password
    4. database host port

  3. Thanks @blacklist, but that still doesn't work. I've checked and doubled checked. I also deleted the db and created a new one.

    It also doesn't explain the fact that I can connect to the db with adminer, but NOT with WordPress. That makes no sense at all.

    Anybody else have ever experienced this with NET Nation? Is this a quirk of theirs? If so, it's very annoying.

  4. Ok turns out, I had a space in between the single quote and the host name. Duh, the error was mine.

    Nothing wrong with the hosting provider, in fact they are the ones who looked at the config.php file for me and fixed it. So Yeah for NetNation.

    Lesson to be learned here: Get someone else to look at your files when you just can't see it. Sometimes you've just been looking at it for too long.

Topic Closed

This topic has been closed to new replies.

About this Topic