Can't connect to db with settings that worked before (2 posts)

  1. JugglerKit
    Posted 10 years ago #

    First, thanks for reading this.

    Problem: Using identical settings to those that work on a current install, can't connect to db with new install.

    System: FreeBSD 4.9, Apache 1.3.31, PHP 4.3.6, MySQL 5.0.16

    I installed a WordPress blog using the MySQL root user (I know, but I had issues getting any other user to work, and I only use MySQL for blogs, and it's not root on the *box*, just in the db ...). Worked fine. I am able to post, administer that blog, everything.

    So, I create a new directory, alias http://www.the-athenaeum.org/blog to go to that directory, put WordPress into it, and use the exact same config.php, except I change the table prefix. This time, however, I get:

    "Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again."

    The only major thing that is different between these two sites (that I can think of) is that one has its own domain (www.artbarplayers.com), and therefore an entry in BIND. The other just has an alias in Apache. But I can't see how that would matter, unless "localhost" in a php context is somehow DNS-dependent.

    I did also have to do the thing to make MySQL use "simple" password hashing, since I have PHP < 5.0. However, I assume the user/password combo is still working, or else I couldn't use the first blog?

    Where else should I look for issues?

    Thanks in advance,

  2. JugglerKit
    Posted 10 years ago #

    Hah. Never mind. It was in fact an arcane Bind issue.

    - Chris

Topic Closed

This topic has been closed to new replies.

About this Topic