Can't connect outside my intranet (2 posts)

  1. VaporLock
    Posted 5 years ago #

    Another noob question here. I've read several posts but they either didn't address my situation, I didn't find the right posts, or I flat out didn't understand them.

    I've set up a personal blog at home. I can access it just fine from within my intranet by going to "http://{server}/blog". But from outside when I try "http://blog.{domain}.org" I can't access it. The browser address bar will first change to "http://www.{domain}.org/blog" then to "https://{server}/blog/wp-login.php?redirect_to=https%3A%2F%2Fwww.{domain}.org%2Fblog%2Findex.php&reauth=1".

    I bought my domain through GoDaddy, and I assume I'm forwarding the subdomain, "blog", correctly since the address first changes to "http://www.{domain}.org/blog". But then why does it change again? I'm guessing I've set something wrong, but I don't know what. And I also assume that the reason I can't access the site outside of my intranet is because once the address changes to "https://{server}/..." the name obviously doesn't resolve to the correct address. Correct?

  2. dholowiski
    Posted 5 years ago #

    Hi, you've done just about everything right. The problem you are having is because your WordPress site is configured for {server}, but when you access it from outside you go to www.{domain}.org
    The redirect is normal, when you visit wp-login.php it redirects you to the long URL you post... except it is using your site setting, so it redirects you to {server} which of course you can't access from the outside world.

    I think the easiest thing to do is to log into the site from home, change the site name (under Settings) to www.{domain}.org, and then just access the site from www.{domain}.org even when you're at home.

    If just changing the site name doesn't work, you might have to go further, as described in this document.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.