Support » Plugin: Jetpack by » Can't connect mobile app to Jetpack stats

  • When I attempt to connect the WordPress iOS app to my site, I’m not able to access my site stats. Instead, I see this message:

    You are not a member of this site.

    If you have just installed the Stats plugin, this error probably appeared because the API key entered in the plugin belongs to a different user account.

    The owner of the API key must visit this site’s stats page to grant access.

    You are logged into as accountname. To switch accounts, log out.

    I’m definitely using the same account in the app that I used when setting up Jetpack.

    I’ve tried looking on, and also on the Jetpack Stats settings on my own site, and I can’t find any place to “grant access”. How do I “grant access” so that the stats function properly on the iOS app?

    This site is a sub-domain sub-site of a Multisite installation. The primary site of this installation uses the same username, and the stats DO work properly for the mobile app.

    This is also a problem for other admins of the site using the Android app.

    The stats had been working for me before, but I’m not sure at what point they stopped working.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Tim Moore


    I’ve reported this to our engineers. Thanks for letting us know and sorry for the inconvenience. I’ll get back to you as soon as I have more information.

    Plugin Contributor daniloercoli


    @jpry – We’re sorry to hear that you’re encountering this issue.
    Coud you please enable the debug option, that enables extended log format, and send us the log file?
    Instructions below:
    – Start the iOS app
    – Open the sidebar
    – Tap the ‘Settings’ button on the bottom of the screen
    – Enable the ‘Extra Debug’ option at the bottom of the page
    – Try to configure the Jetpack Stats again
    – Send us the log file by email to mobile [at]

    Detailed instructions here :

    I’m having the same issue as well, but on the android app. It’s been going on since I went back to WordPress a couple of weeks back now and it’s really frustrating. I’ve tried everything but nothing works.

    Plugin Contributor daniloercoli


    @anna-maria Eriksson – What is the URL of your self-hosted site?

    I’ve just sent the email with my log file attached. If there is anything else I can provide, let me know.

    @danilercoli I’m having this issue on all of my subdomain sites in my multisite network. It works fine on my main site. You can have the url to my blog in english – Click this link.

    Plugin Contributor daniloercoli


    @jpry – Thanks for sending us the log file. We’re looking into this problem and will post updates as we have more information on this.

    @anna-maria Eriksson – Coud you please enable the debug option, and try to access Stats for one of your subdomain blog (Instructions above)?

    I did that now and I get this message within my site’s stats:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /storage/content/30/——/ on line 2722

    The hyphens in the url replaced an account numbers. Just ignore it.

    Plugin Contributor designsimply



    Just to make sure, are you using the latest versions of both WordPress (which is 3.4.2) and Jetpack (which is 2.0)?

    I am having the same problem. I turned on debug but didn’t receive any more information than to double check I have the latest versions (I do) and that it is connected to the correct account (it is).

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can't connect mobile app to Jetpack stats’ is closed to new replies.