WordPress.org

Support

Support » Installation » [Resolved] Can't connect Mamp to WP

[Resolved] Can't connect Mamp to WP

  • amycalhoun
    Member

    @amycalhoun

    I have mamp installed and when I try to connect to the servers, only apache will light up. I can’t connect to MySql.

    I am following directions on:
    http://documentation.mamp.info/en/mamp/how-tos/check-the-default-storage-engine-of-mysql

    documentation says to open terminal and type in: /Applications/MAMP/Library/bin/mysql –host=localhost -uroot -proot

    I get the message: Can’t connect to local MySQL server through socket ‘/Applications/MAMP/tmp/mysql/mysql.sock’ (2)
    unknown8c2daa416ac9:~ Amy$

    Overall goal is to get MAMP working for a WP theme.

    Many Thanks
    Amy

Viewing 7 replies - 1 through 7 (of 7 total)
  • bemdesign
    Member

    @bemdesign

    Weird. Usually when you install MAMP everything works fine out of the box with no need to configure anything – it’s part of the beauty of MAMP!

    Have you tried re-installing MAMP?

    amycalhoun
    Member

    @amycalhoun

    Yes, I reinstalled it twice.

    bemdesign
    Member

    @bemdesign

    Are you using MAMP Pro or just MAMP? With just MAMP you’ll also need to include the ‘:8889’ port number at the end of ‘localhost’ as not-MAMP Pro uses non-standard ports to help keep your machine secure while running Apache and MySQL.

    So in that terminal command try this:

    /Applications/MAMP/Library/bin/mysql --host=localhost:8889 -uroot -proot

    amycalhoun
    Member

    @amycalhoun

    I am using MAMP ( not the pro version ) and I have the 8889 entered in the Mamp preferences:

    Here is what I got when I entered your command above.

    Last login: Sat Mar 29 15:17:39 on ttys000
    unknown8c2daa416ac9:~ Amy$ /Applications/MAMP/Library/bin/mysql –host=localhost:8889 -uroot -proot
    ERROR 2005 (HY000): Unknown MySQL server host ‘localhost:8889’ (0)
    unknown8c2daa416ac9:~ Amy$

    bemdesign
    Member

    @bemdesign

    Hmmm. So when the MAMP control panel is up, clicking start doesn’t launch the MySQL server? Have you checked Activity Monitor to confirm that there’s no MySQL process running – at all – either using the MAMP launcher or the terminal commands?

    At this point you probably need to check with the MAMP or MySQL folks for support as this is definitely a MySQL on Mac issue and less about WordPress…

    Sorry I couldn’t help resolve the issue – best of luck and I hope you get it resolved!

    Oh random thought – is your user account an Administrator on the Mac? Can you use “sudo” when launching the command and see if that helps? Might be an account privilege issue…

    amycalhoun
    Member

    @amycalhoun

    Ok, So I got some advise from another source and had ZERO problems getting a local server set up for word press. Here is the info in case someone else needs help.

    1 step local wordpress installation forget xammp, wamp, etc… bitnami has 1 step local stack wordpress installation so you can work locally on your site. The stack installs everything you need.

    https://bitnami.com/

    They have dozens of applications that you can install with 1 or two clicks and you don’t have to know a thing about setting up local servers, etc.

    sign up for a free account, verify your email address and then click for easy installation!

    https://bitnami.com/stack/wordpress

    PC or Mac … Local machine, virtual machine, or cloud!

    amycalhoun
    Member

    @amycalhoun

    Thank you bemdesign for trying! I appreciate your efforts!
    Amy

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Can't connect Mamp to WP’ is closed to new replies.