Support » Plugin: ActivityPub » Can#t connect from my friendica site

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Author Matthias Pfefferle

    (@pfefferle)

    Hey @regenpfeifer

    it is needed to have the author page enabled, but yours seem to redirect: https://regenpfeifer.eu/author/regenpfeifer

    Cheers.

    Thread Starter regenpfeifer

    (@regenpfeifer)

    Thank you, @pfefferle ,

    I have now deactivated the redirection and the author page seems to work:
    https://regenpfeifer.eu/author/regenpfeifer/

    Nevertheless I am getting an error messsage, if I try to add my WordPress profile “regenpfeifer@regenpfeifer.eu” in Friendica (in german): “Der Netzwerktyp wurde nicht erkannt. Der Kontakt kann nicht hinzugefügt werden.”

    The URL I get when I try to add the profile is:
    https://friends.regenpfeifer.net/follow?url=regenpeifer%40regenpfeifer.eu

    I can add other contacts / profiles via ActivityPub in my Friendica-instance without problems.

    If I add the profile via the URL https://regenpfeifer.eu/author/regenpfeifer/, I am again ending up at an ATOM/RSS-connection.

    • This reply was modified 1 year, 1 month ago by regenpfeifer.
    Plugin Author Matthias Pfefferle

    (@pfefferle)

    It seems, that your blog does not recognice “Accept” header.

    This request:

    curl "https://regenpfeifer.eu/author/regenpfeifer/" \
         -H 'Accept: application/activity+json'

    should return JSON, but it returns the HTML source of your post.

    Thread Starter regenpfeifer

    (@regenpfeifer)

    Thank you, @pfefferle, what can I do to change this?

    My apache server is configured to run with HTTP/2, could this be the cause?

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    For “POST” it seems to work:

    curl -X "POST" "https://regenpfeifer.eu/author/regenpfeifer/" \
         -H 'Accept: application/activity+json'

    This is weird! Are you aware of any restrictions on your hosting?

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    @regenpfeifer no, I also use HTTP/2 on my server. I will think about it.

    Thread Starter regenpfeifer

    (@regenpfeifer)

    @pfefferle, thank you very much for your support!

    I can’t think of any restrictions of my hosting. My site is hosted at an own server, running Debian 10 Buster, Apache 2.4 with PHP 7.4 / php-fpm and mpm_event.

    My VHost file doesn’t have any special restrictions, too. I have deactivated Content-Security for the moment; “Referrer-Policy” and “Access-Control-Allow-Origin” (“*”) are set.

    In a former installation of my site (I have changed the server recently) ActivityPub worked fine…

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Can you send me a profile URL of the friendica instance?

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Have you installed any security plugins, that might block this request/header?

    Thread Starter regenpfeifer

    (@regenpfeifer)

    This is my own profile at my friendica instance:
    https://friends.regenpfeifer.net/profile/regenpfeifer/profile

    I am not aware of any security plugin. I will check the security options of Jetpack, maybe some setting there is preventing the request.

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    There it works:

    curl "https://friends.regenpfeifer.net/profile/regenpfeifer/profile" \
         -H 'Accept: application/activity+json'

    Any differences in the config? can you try to temporary disable the other plugins?

    Thread Starter regenpfeifer

    (@regenpfeifer)

    Hello @pfefferle,

    now I managed to get it working. The reason for the problems was a Jetpack setting which is meant to block brute-force-attacks. I have set the IP-address of my friendica site as allowed – and now everything seems fine!

    Thank you again for your support!

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Oh, nice that it was so “easy” in the end 🙂

    tiotrom

    (@tiotrom)

    Same issue here…. @tiotrom@tiotrom.com not working with my https://venera.social/ Friendica instance that I use. I deactivated any plugins that may block any IP addresses….so I am confused as to how to make it work. Any help please?

    • This reply was modified 1 year ago by tiotrom.
    Thread Starter regenpfeifer

    (@regenpfeifer)

    Same issue again for me. It seems, that it was not Jetpack, which blocked my Activity Pub connection. Maybe it could be Cloudflare CDN? I am experiencing the problem with two websites, both of them are connected via Cloudflare.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Can#t connect from my friendica site’ is closed to new replies.