Support » Plugin: WP-United : phpBB WordPress Integration » Can't connect dots on New User Permissions

  • I’m not sure if I’m missing something or not but the blue and red connector dots cannot be connected to anything that makes sense.

    Basically, all the dots start out as on-top of eachother in the top right corner, and then get stuck there. Is there something I’m missing?

Viewing 15 replies - 1 through 15 (of 15 total)
  • I am having a similar problem; the dots are at the upper left for me. WP 3.6.1, WP-United Locally I’m on OSX 10.8. Tried current versions of Safari, Firefox and Chrome… all of them had the same problem with the dots

    I’m having problems with the user integration in general but it’s probably because I cannot set up new user permissions because of the connect-the-dots problem. I would really like to get this working on my site as it’s a fantastic idea.

    Same Problem here. checking the wp-united support board there are reported cases of this going back to August 24th unresolved.

    PHPbb installation I have the following installed

    Post Count Requirements
    phpBB Invite

    I am running 2.6.1 in wordpress, was 3.6.0 but upgraded to see if that would resolve issue

    [b]WP-United Version[/b]        :
    [b]WordPress Version[/b]        :     3.6.1
    [b]PHP Version[/b]              :     5.3.13
    [b]WP-United enabled?[/b]       :     Yes
    [b]WordPress Home URL[/b]       :
    [b]WordPress Base URL[/b]       :
    [b]WordPress Plugin URL[/b]     :
    [b]phpBB URL[/b]                :
    [b]Plugin Path[/b]              :     /are/hidden/for/safety.some/ised/all/ele/
    [b]WordPress Path[/b]           :     /are/hidden/for/safety.some/
    [b]phpBB Path[/b]               :     /are/hidden/for/safety.some/ments/
    [b]Active plugins[/b]           :     bbpress-admin-bar-addition/bbpress-admin-bar-addition.php, bbpress-new-topic-emailer/bbpress-new-topic-emailer.php, bbpress-post-toolbar/bbpress-post-toolbar.php, bbpress/bbpress.php, brankic-social-media-widget/bra_social_media.php, feedwordpress/feedwordpress.php, fwp-sic-em/SicEm.php, gd-bbpress-tools/gd-bbpress-tools.php, wordpress-importer/wordpress-importer.php, wp-united/wp-united.php
    [b]Current theme[/b]            :     Good News
    [b]Allocated memory[/b]         :     37584.003898635M
    [b]Memory limit[/b]             :     256M
    [b]Locale[/b]                   :     en_US
    [b]integrateLogin[/b]           :     1
    [b]showHdrFtr[/b]               :     REV
    [b]wpSimpleHdr[/b]              :     1
    [b]dtdSwitch[/b]                :     0
    [b]phpbbCensor[/b]              :     1
    [b]wpPageName[/b]               :     page.php
    [b]phpbbPadding[/b]             :     6-12-6-12
    [b]xposting[/b]                 :     1
    [b]phpbbSmilies[/b]             :     0
    [b]avatarsync[/b]               :     1
    [b]integcreatewp[/b]            :     1
    [b]integcreatephpbb[/b]         :     1
    [b]xpostautolink[/b]            :     0
    [b]xpostspam[/b]                :     all
    [b]xpostforce[/b]               :     -1
    [b]xposttype[/b]                :     excerpt
    [b]xpostprefix[/b]              :     [BLOG]
    [b]cssMagic[/b]                 :     0
    [b]templateVoodoo[/b]           :     0
    [b]useForumPage[/b]             :     1
    [b]wpuxpostcomments[/b]         :     0

    As cool as dragging blue dots around the screen is I think simple dropdowns would get the job done cleaner

    I’m experiencing the same issue.

    [b]WP-United Version[/b] :
    [b]WordPress Version[/b] : 3.6.1

    Does anyone know if it’s possible to change the permissions manually until the bug gets fixed?

    I spent a fair amount of time trying to find where the permissions were stored in the database in the hopes that I could set them manually, but with no luck. I’m not enough of a coder to understand what’s going on in there.

    I resolved this.

    It’s not very clear, but the New User Permissions page in the WordPress admin area is an alternative way to setting up the permissions. It’s meant to be easier because you can “visualize” the connections between account groups. Obviously, this isn’t helpful because all of our connectors are glitched.

    But anyways, the fix is that you can also set these permissions in the phpBB ACP as well (admin area). Remember how you had to install a phpBB plugin?

    So log in to your phpbb ACP, go to “Permissions”, then click “Group permissions” on the left. Select the group you want to edit, then click “Advanced Permissions”. You’ll have a WP-United tab that you can now set the correct levels on.

    Thank you for the workaround! I have given it a try and will test tonight


    Although i set the desired permissions to my phpbb ACP for all groups of users,this thing does not work.

    Any ideas?

    I am using WordPress 3.6.1 + phpBB 3.0.11 .

    It seems generally buggy, and it doesn’t appear to officially support WP 3.6.1. Like I said, fantastic idea, but needs some work to be fully functional and reliable. The other problem I had is that I was constantly being logged out of PHPBB. I chalked it up to not being able to set the user permissions properly, but it could be another bug. I turned the whole thing off for now.

    Are there any alternatives out there (for the login part only)?

    Hello, I have the same problem with my wp version 3.6.1. I am going crazy as I can’t sync the users between the forum and the wp site. My site is going live. Please help me find a solution. I think the problem is somewhere in the js file and

    I found an error in the js console.

    Uncaught TypeError: Cannot set property ‘_renderItem’ of undefined in settings.js

    Is the wp united support team having a look at this thread??

    Thank you in advance.



    Thanks. This method worked for me.

    @martin_wray1 does cros posting work too for you. I thought it was working but can not get Blog posts to show up in forum


    I havent tested that aspect of it.


    Here is fix, taken from

    in wp-united/settings.js

    .data('ui-autocomplete')._renderItem = function(ul, item) {
    				var statusColor = (item.statuscode == 0) ? 'red' : 'green';
    				return $wpu('<li></li>')
    					.data('ui-autocomplete-item', item )
    					.append( '<a><small><strong>' + item.label + '</strong><br />' + item.desc + '<br /><em style="color: ' + statusColor + '">' + item.status + '</em></small></a>')
    					.appendTo( ul );

    I reverted back to 3.5 in my test environment and the user mapping worked fine, so i think it just broke at some version of wp 3.6ish.

    For the fix able setting these permissions in phpbb instead of the user mapper, can someone elaborate or give an example on how that worked?


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can't connect dots on New User Permissions’ is closed to new replies.