Support » Plugin: Mailchimp for WooCommerce » cant connect

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support khungate

    (@khungate)

    Hi @nelissar, sorry to hear you’re having issues with the plugin, we definitely want to try to help out. Just to get a handle on the situation you’re experiencing, could you provide a few more pieces of information to help us understand the issue?

    – What plugin version are you using?
    – What version of PHP are you using?
    – Are there any fatal errors in WooCommerce? (WooCommerce -> Status -> Logs)
    – If you have a large number of plugins being used, you may need to bump up your memory limit on your server (1GB for example) to accommodate the initial sync.
    – If you haven’t already, please browse through our wiki to find documentation on the most common issues and how to resolve them: https://github.com/mailchimp/mc-woocommerce/wiki

    Thanks in advance for these details. I’ll keep an eye out for your reply.

    I have exactly the same problem with the same thing.
    plugin version 2.4.5
    PHP 7.2
    in the WooCommerce -> Status -> Logs
    CRITICAL Uncaught Error: Call to a member function is_preview_mode
    memory for website – 1024MB (1GB)
    already connected elementor pro with woocommerce api so I don’t understand why this plugin can’t connect.

    • This reply was modified 2 months, 3 weeks ago by loveasaf.

    hi,
    plugin version:2.4.5
    php version: 7.2.33
    the errors I see:

    <input type=”hidden” name=”__VIEWSTATEGENERATOR” id=”__VIEWSTATEGENERATOR” value=”01966F9E” />
    <div>
    <span id=”status”>IPN</span> <br />
    <span id=”ResultJSON”>{“client_message”:””,”debug_message”:””,”error_code”:0,”data”:{“client_message”:null,”debug_message”:null,”error_code”:0,”document_data”:{“document_type”:2,”document_number”:501617,”document_identity”:”3a61513b-0c05-482f-92a0-ff980e38eb87″,”document_link”:”https:\/\/api.rivhit.co.il\/pdf\/FileService.svc\/GetDocument\/038347183\/3a61513b-0c05-482f-92a0-ff980e38eb87\/true\/02_501617″},”receipt_data”:null}}</span> <br />
    <span id=”ResultXML”><?xml version=”1.0″ encoding=”utf-16″?>
    <DocumentNewResponse xmlns:xsd=”http://www.w3.org/2001/XMLSchema&#8221; xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”&gt;
    <error_code>0</error_code>
    <client_message />
    <debug_message />
    <data>
    <error_code>0</error_code>
    and

    <input type=”hidden” name=”__VIEWSTATEGENERATOR” id=”__VIEWSTATEGENERATOR” value=”01966F9E” />
    <div>
    <span id=”status”>IPN</span> <br />
    <span id=”ResultJSON”>{“client_message”:””,”debug_message”:””,”error_code”:0,”data”:{“client_message”:null,”debug_message”:null,”error_code”:0,”document_data”:{“document_type”:2,”document_number”:501617,”document_identity”:”3a61513b-0c05-482f-92a0-ff980e38eb87″,”document_link”:”https:\/\/api.rivhit.co.il\/pdf\/FileService.svc\/GetDocument\/038347183\/3a61513b-0c05-482f-92a0-ff980e38eb87\/true\/02_501617″},”receipt_data”:null}}</span> <br />
    <span id=”ResultXML”><?xml version=”1.0″ encoding=”utf-16″?>
    <DocumentNewResponse xmlns:xsd=”http://www.w3.org/2001/XMLSchema&#8221; xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”&gt;
    <error_code>0</error_code>
    <client_message />
    <debug_message />
    <data>
    <error_code>0</error_code>

    @nelissar so what do I do with it ?

    also tried health check’s troubleshooting only activating woocommerce and mailchimp for woocommerce – nothing. same bugged screen

    • This reply was modified 2 months, 3 weeks ago by loveasaf.

    @loveasaf I am waiting for the answer from support..started this thread lol

    • This reply was modified 2 months, 2 weeks ago by nelissar.
    Plugin Author ryanhungate

    (@ryanhungate)

    @nelissar @loveasaf wow – this is most certainly a new bug report 🙂 Sorry for the delay in responding.

    The function is_preview_mode is not called by our plugin – but that doesn’t mean that we didn’t trigger a function that could have found it’s way into another wordpress hook or woocommerce hook to surface. The function not being there means you’re missing a dependency or the conflicting plugin itself might be making a mistake by assuming a function existed. Either way that’s nothing we could control. Does it happen to have the “stack trace” along with it so we can walk through the code tracing and see where the problem originated?

    @nelissar Do you by chance have your site language to Hebrew? We’ve recently found something that needs to be addressed while using the Hebrew language and it’s being resolved in our next release coming out shortly.

    We’ve seen that if you temporarily switch back to english – the plugin connects just fine – but yes you can expect a resolution to this one shortly when 2.4.6 comes out.

    @khungate followed all instructions unfortunately no change. please watch this so we make sure the problem is clear-
    https://www.loom.com/share/7a2875c91a36491dbc4f0da45ade5c91

    thank you

    Plugin Support khungate

    (@khungate)

    @nelissar thank you for the screencast, very helpful. As @ryanhungate noted above, we have a patch issued for Hebrew languages due out in our upcoming release. If you’d like a temporary workaround, please temporarily switch your site back to English and it should connect with no issue. If you’d like to wait that’s totally fine, v2.4.6 should be rolled out in the near future.

    @khungate thx for your reply. as you can see yes the site is in Hebrew. can’t change to English so I’ll have to wait for the next update just hope it will be soon.

    Plugin Author ryanhungate

    (@ryanhungate)

    @nelissar please give the latest plugin a download ( 2.4.6 ) that should resolve the issues you were bringing to our attention. Thanks so much for reaching out – and please let us know if this resolved your issues.

    @ryanhungate, indeed the last update solved some of the issue however once I put my mailchimp user name and password I get this error:
    Mailchimp says: API Request Error – 500 :: CURL error :: Couldn’t bind to ‘the.ip.address’ on 1823 in /home/shiratha/public_html/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

    Plugin Author ryanhungate

    (@ryanhungate)

    @nelissar seems that you’re copying that directly from the docs area – the.ip.address is supposed to be replaced with your actual dedicated IP address that you’re using 🙂 That would never work as is. Once you change this to the correct value please report back.

    @ryanhungate this is the message I am seeing
    https://www.loom.com/share/ca10d864571f41f2a2635a1098e4892d

    • This reply was modified 1 month, 4 weeks ago by nelissar.
    Plugin Author ryanhungate

    (@ryanhungate)

    @nelissar Thanks for the screen cast – but we’re still using the same recommendations to resolve it which I’ve described above.

    There’s a manual override for changing the outbound ip address for servers that might need to specify a specific IP. This is used for shared hosting typically to get around being blacklisted from Mailchimp’s API gateway service.

    The error message indicates that someone did a direct copy/paste from our documentation but did not change the actual value of the ip address which is why you’re seeing that specific error message.

    Can you please take a look at your wp-config.php file and make sure that this is set correctly, or commented out? This is the issue for sure. The plugin is using this override but it was not set up properly.

    thanks for the explanation. seems to work now.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.