Support » Plugin: Mailchimp for WooCommerce » Can’t Connect

  • Resolved pintillo86

    (@pintillo86)


    Trying to connect the plugin, did the login step, the pop up window closed, and the plugin got stucked in the connect tab, it says: “Connection in progress” but nothing happens. Please help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • pintillo86

    (@pintillo86)

    I checked the Console, and its giving me the following error: “Error calling OAuth finish endpoint.”

    Plugin Author ryanhungate

    (@ryanhungate)

    @pintillo86 do you mind trying this again and let us know if you’re still having trouble? Also – if you could please tell us your site’s URL that might help us find some logs to troubleshoot better. If you would rather send them to us privately – please send them to ryan ( at ) vextras.com – I’ll be glad to look into this for you.

    pintillo86

    (@pintillo86)

    Hey @ryanhungate I have just sent you an email!

    pintillo86

    (@pintillo86)

    So for all you guys with a similar issue! Ryan Helped me a lot, at the end the problem was that the way my memcached system is working was blocking the “secret” site transient.
    SOLUTION
    Turn all caching systems off while installing the plugin, and it worked fine!

    Plugin Author ryanhungate

    (@ryanhungate)

    @pintillo86 thanks again for working through things with us. Also, thank you very much for the review. It’s much appreciated. 🙂

    For anyone else that’s looking at this ticket running into the same problem, there is a universal “try this first” of turning off your caching plugins while you’re setting up the plugin. Or if at all possible, simply ignore caching on the admin pages with a wildcard instead.

    Not everyone’s problems are the same, plugins are different, so it’s not a 1 size fits all answer. In this case you can see the problem was related to not being able to finish the OAuth process. If you run into this problem – please try what we recommended in this post first before posting another ticket.

    Turned of Cache and it finished connecting almost instantly. Thanks for sharing the info.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.