Support » Plugin: Cloudflare » Can’t Configure Settings in 3.0.2

  • I had the 1.xx version of the plugin installed. When I upgraded to 3.0.0 it broke my website, so I disabled it. The problem was not fixed in 3.0.1, so I removed the plugin completely while waiting on an update.

    I just installed 3.0.2, there are no server errors, but now I can’t configure the settings. On the settings page I see a drop down under “Active Zone.” When clicking the drop-down, there is nothing to choose from.

    At the bottom of the page it says: “Please select a domain that is provisioned with CloudFlare.” But there is no option to add my domain or API.

    I also see 3 navigation areas: “Home” “More Settings” and “Analytics.” All 3 of those pages display the exact same thing.

    Could this be caused from removing the plugin after it was working in 1.xx?

    Thanks

Viewing 14 replies - 16 through 29 (of 29 total)
  • Hi @sebadler @brandomeniconi @ybzybz,

    In the dropdown is there a domain selected by default?

    If your website was not added to your Cloudflare account the active zone should not show anything. Could you verify you logged in with the correct Cloudflare account.

    If you have multiple Cloudflare accounts and you’re not sure which one you logged in to the plugin with deactivating and reactivating the plugin will logout your current account then you can log in with the correct Cloudflare account.

    • This reply was modified 4 years, 7 months ago by thellimist.

    @thellimist,

    In my case – the dropdown does not present anything by default. I have 3 domains on cloudflare, but I normally use only one. I definitely know to which domain I logged on to and it is the relevant one for this website.

    Just to be on the safe side – I’ve deactivated, reactivated the plug in and logged back on. Didn’t help… still not working.

    One thing comes to mind – I am using W3TC with the CloudFlare extension. Maybe there is conflict there?

    @ybzybz,

    Can you confirm that your Cloudflare account has “yourwebsite.com” domain and when you are viewing Cloudflare plugin in the wp-admin the url is “yourwebsite.com/pathtowordpress/wp-admin/options-general.php?page=cloudflare”

    The plugin should work fine with W3TC.

    This is the URL:

    mydomain.com/pathtowp/wp-admin/options-general.php?page=cloudflare#/home?_k=[6 chr string]

    By now I downgraded to 1.3.24, but I remember that my current domain was in the select by default. I cannot change anything and I see only three blue buttons. But they don’t do anything apart from changing the URL #hash.

    If you want I can update to 3.X and give you a temporary admin login. My website is hosted @ Google GCE with Bitnami WordPress Image. Theme: The Ken.

    Thanks.

    @thellimist,

    I am not sure if I understand what you are asking me about,

    • I do not have any dropdowns or settings or anything I can adjust
    • The plugin settings, display a blank gray page
    • I found nowhere in my wp-admin or on my CF account that indicates whether the plugin is working or not
    • I tried to deactivate and activate the plugin, and there is no change in the behaviour
    • I tried to reinstall the plugins and still no change
    • Some questions:

    • I do have multiple Accounts, but why should that have anything to do with the issues since the plugin should activate by me inserting both my API key and e-mail address?
    • Has the install procedure you describe on WordPress.org changed in version 3?
    • Could the error be related to me changing my e-meail(login) on my CloudFlare account recently?
    • All my WP installs are running in a subdirectory for security reasons, is that a problem?
    • – and if so, how do i remove my API key and e-mail to re-activate the plugin?
    • Do I need an active paid plan on the domain to use the plugin?
    • Where can I see if the plugin is connected(talking to CloudFlare) or not?
    • Did you betatest this product with IIS webserver, various popular WP plugins and themes?
    • Is the plugin PHP 7.0 compatible?
    • Is the plugin MySQL 5.6 compatible
    • Please Confirm

      Seb.

    • This reply was modified 4 years, 7 months ago by sebadler. Reason: formatting

    Sorry I wasn’t clear enough.

    In cloudflare.com dashboard you can see the domains you’ve registered to Cloudflare.

    Do you access your wp-admin from the same domain?

    In example:
    Your cloudflare.com dashboard has “bosxlabzz62.com”
    Your WordPress wp-admin link is “bosxlabzz62.com/wp-admin/options-general.php?page=cloudflare…”

    • This reply was modified 4 years, 7 months ago by thellimist.
    • This reply was modified 4 years, 7 months ago by thellimist.

    @thellimist,

    In my case, the answer is Yes, I use the very same domain.
    The only thing that might be different is that the “WordPress Address (URL) is a subdirectory under the “Site address (URL)”.

    @thellimist,

    Yes I access it from domainname.com/login

    and the i get redirected to a subfolder:

    domainname.com/root-dmn/wp-login.php

    Domainname.com is the same domain as in the dropdown field on my CF accounts.

    Seb

    • This reply was modified 4 years, 7 months ago by sebadler.

    If it’s of any help, I have just set up a brand new site [i.e. default theme, no plugins, no modifications]. It is installed in the domain root. The domain runs through CloudFlare and is active.

    I installed CloudFlare 3.0.2 plugin. It asked for CloudFlare credentials – email and API key which I entered. Clicking on the “Save API Credentials” button does nothing. The only thing I can do on the page is enter text, as nothing else works including images.

    I rolled back to V 1.3.24 and that worked perfectly.

    @curraman @sebadler

    Could you submit a support ticket to help us investigate this issue further. Please add this topics link to the support ticket.

    Thanks.

    Ticket submitted.

    • This reply was modified 4 years, 7 months ago by Curraman. Reason: removed error

    Upgraded to CloudFlare V3.0.3

    Kills the site – blank screens all around. Had to disable the plugin folder to restore the site.

    @curraman,

    Thank you for the alert!
    Any one else tried 3.0.3?

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘Can’t Configure Settings in 3.0.2’ is closed to new replies.