Support » Plugin: Active Directory Integration / LDAP Integration » Cant configure ldap in debian

  • Resolved drakeyboy

    (@drakeyboy)


    Hi getting several errors when trying to install/enable ldap via shell command, output below, any help much appreciated:
    root@debian:~# apt-get install php-ldap
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    php-ldap is already the newest version (1:7.0+49).
    The following packages were automatically installed and are no longer required:
    icedtea-netx icedtea-netx-common
    Use ‘apt autoremove’ to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 41 not upgraded.
    3 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up php7.0-ldap (7.0.33-0+deb9u3) …
    /var/lib/dpkg/info/php7.0-ldap.postinst: 215: /var/lib/dpkg/info/php7.0-ldap.postinst: phpquery: not found
    dpkg: error processing package php7.0-ldap (–configure):
    subprocess installed post-installation script returned error exit status 127
    Setting up php7.0-fpm (7.0.33-0+deb9u3) …
    /var/lib/dpkg/info/php7.0-fpm.postinst: 43: /var/lib/dpkg/info/php7.0-fpm.postinst: phpquery: not found
    dpkg: error processing package php7.0-fpm (–configure):
    subprocess installed post-installation script returned error exit status 127
    dpkg: dependency problems prevent configuration of php-ldap:
    php-ldap depends on php7.0-ldap; however:
    Package php7.0-ldap is not configured yet.

    dpkg: error processing package php-ldap (–configure):
    dependency problems – leaving unconfigured
    Processing triggers for libapache2-mod-php7.0 (7.0.33-0+deb9u3) …
    Errors were encountered while processing:
    php7.0-ldap
    php7.0-fpm
    php-ldap
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@debian:~# apt-get install -f
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    The following packages were automatically installed and are no longer required:
    icedtea-netx icedtea-netx-common
    Use ‘apt autoremove’ to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 41 not upgraded.
    3 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up php7.0-ldap (7.0.33-0+deb9u3) …
    /var/lib/dpkg/info/php7.0-ldap.postinst: 215: /var/lib/dpkg/info/php7.0-ldap.postinst: phpquery: not found
    dpkg: error processing package php7.0-ldap (–configure):
    subprocess installed post-installation script returned error exit status 127
    Setting up php7.0-fpm (7.0.33-0+deb9u3) …
    /var/lib/dpkg/info/php7.0-fpm.postinst: 43: /var/lib/dpkg/info/php7.0-fpm.postinst: phpquery: not found
    dpkg: error processing package php7.0-fpm (–configure):
    subprocess installed post-installation script returned error exit status 127
    dpkg: dependency problems prevent configuration of php-ldap:
    php-ldap depends on php7.0-ldap; however:
    Package php7.0-ldap is not configured yet.

    dpkg: error processing package php-ldap (–configure):
    dependency problems – leaving unconfigured
    Processing triggers for libapache2-mod-php7.0 (7.0.33-0+deb9u3) …
    Errors were encountered while processing:
    php7.0-ldap
    php7.0-fpm
    php-ldap
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@debian:~#

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author miniOrange

    (@cyberlord92)

    It is possible that you have multiple PHP versions installed. If that is the case, you would need to install the LDAP extension for the version which is active.

    If you are facing issues in installing this, you can send out an email to info@xecurify.com. We can reach out to you over email.

    Plugin Author miniOrange

    (@cyberlord92)

    Marking this as resolved

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.