Support » Plugin: Wordfence Security - Firewall & Malware Scan » Can’t configure firewall on SiteGround

  • Resolved susantau

    (@susantau)


    Hi,

    I had no problems installing Wordfence on all my WordPress sites EXCEPT my 2 sites on SiteGround. This is what happened:

    Basic installation of the Wordfence free plugin goes smoothly – except for a notification at the top of the screen that indicates the firewall still needs to be configured to benefit from extended versus basic firewall protection. But selecting the preselected configuration (Apache + SuPHP) did nothing – even after long waits and refreshing the page.

    I contacted SiteGround support and was told I need to select Apache + CGI/FastCGI. Which I did — but that didn’t work either.

    SO then I followed the instructions for Web Application Firewall Setup and the section specifically concerning SiteGround at https://docs.wordfence.com/en/Web_Application_Firewall_Setup#If_installation_completes_without_errors_but_the_firewall_still_shows_Basic_WordPress_Protection

    In cPanel, I added the variable auto_prepend_file = mypath to my subdirectory where my WordPress installation is and saved to all subdirectories. Then I went back to the WordPress Dashboard and the Wordfence firewall configuration page and selected Apache + CGI/FastCGI — but after waiting half an hour, still nothing has changed. My firewall protection still says “Basic” versus “Extended.”

    Could you please tell me what I’m doing wrong? Wordfence is such an excellent product, I really want it working without hitch on both of my SiteGround sites.

    Thank you!

    Susan

    • This topic was modified 4 years, 7 months ago by susantau.
Viewing 4 replies - 16 through 19 (of 19 total)
  • Thread Starter susantau

    (@susantau)

    In my first Wordfence installation on a SiteGround hosted site, SiteGround Support optimized my WordFence firewall for me. They added the auto_prepend_file path to the php.ini file, but they did not also add the line SetEnv PHPRC… to the .htaccess file. But — extended Wordfence firewall protection works – it’s now enabled on that site.

    When I did this without SiteGround’s help for a second WordPress site, I added the auto_prepend_file path to the WordPress installation root php.ini file. However, extended firewall protection was NOT enabled until I ALSO added the SetEnv line to the .htaccess.

    My guess is that SiteGround Support used a different method for telling PHP which php.ini file to use so didn’t need to add the line to the .htaccess file.

    Note: both the php.ini and .htaccess files to be modified are inside the WordPress installation root directory (not the domain root).

    • This reply was modified 4 years, 7 months ago by susantau.
    • This reply was modified 4 years, 7 months ago by susantau.

    Just to add to this thread, as the above methods weren’t working for me on the Siteground installation. The following video tutorial was suggested by Siteground support, and it worked flawlessly. It involves adding the auto_prepend_file variable through cPanel.

    • This reply was modified 4 years, 5 months ago by .
    Thread Starter susantau

    (@susantau)

    Cool – I know I’ll be needing this again soon.

    Thanks for posting that!

    Glad to see our video is helping out! Here is a link to the post as well:

    https://www.flyingvgroup.com/2017/10/12/configuring-wordfence-security-firewall-with-siteground-hosting/

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Can’t configure firewall on SiteGround’ is closed to new replies.