Support » Plugin: WooCommerce Shipping & Tax » Can’t configure Canada Post Shipping Zone

  • Resolved painterofthreads

    (@painterofthreads)


    I have installed the plug-in and I keep having errors and issues using it. First there was no shipping zones showing up in the cart when calculating shipping, then I tried to configure the shipping zones for Canada Post woocommerce services and I am getting an “unexpected server error” when I attempt to update my postal code and it continues to ask “Now add your zip code and chose which services you want to offer your customers.”

    I am in Canada, I have everything set for Canada as my country of origin etc,any help would be appreciated.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Contributor danreylop

    (@danreylop)

    Hi,

    We’re sorry you’re experiencing those troubles setting up the plugin.

    During the past week we’ve been fixing some problems with our Canada Post integration, could you please try again? Even if it doesn’t work, at least the exact error will be reported so we can fix it.

    I am also in Canada, it gives me no shipping methods available. I have left a flat rate in for now but please help quickly.

    Plugin Contributor Jeff Stieler

    (@jeffstieler)

    @sofanalina

    I’m noticing some Canada Post errors come in where packages have a defined weight, but not any physical dimensions.

    Is there any chance the products you’re attempting to get rates for don’t have weight or dimension information?

    • This reply was modified 3 years, 7 months ago by Jeff Stieler.

    I have updated the plugin and tried to add my postal code of origin and I am still getting “unexpected server error”

    Plugin Contributor danreylop

    (@danreylop)

    Hi @painterofthreads,

    We have found a possible explanation. We believe that our plugin is incompatible with certain configurations of mod_security. We are working on a solution right now, but in the meantime, could you please try to disable mod_security in your server and try again?

    If your hosting uses cPanel, it should be an option inside the “Security” section, called “ModSecurity”. Don’t worry, if you keep WordPress and your plugins updated, you’re not vulnerable to hacking even if you disable “ModSecurity”.

    We’ll keep you updated on our progress fixing this so you can enable it again.

    Plugin Contributor danreylop

    (@danreylop)

    Hi again @painterofthreads,

    We’ve confirmed the incompatibility with mod_security and we fixed it already. If you still haven’t followed the instructions of my previous message, you can ignore it and update to the new version of WooCommerce Services (1.3.1) instead. That should fix your problem.

    If you already disabled mod_security, once you update WooCommerce Services to the version 1.3.1 you can safely enable it again if you want.

    Cheers!

    I updated the plugin, but still get the same error, I did not disable the mod-security.

    Still not resolved, I use siteground and they do not recommend disabling mod security entirely. I also cannot see mod_security in the cPanel, help would be appreciated.

    Plugin Contributor danreylop

    (@danreylop)

    Hi @painterofthreads,

    You should find the option to disable mod_security (maybe called ModSecurity) in the Security section of cPanel. But I don’t know how SiteGround is configured so maybe they don’t even allow to disable it.

    Disabling it entirely is not advisable, but it’s the first step to solve your issue: checking that it’s actually caused by mod_security.

    Roughly speaking, mod_security is a firewall that can be configured to “block” certain types of “suspicious” requests to your server. It can be configured with a set of “rules” to determine if a request should or shouldn’t be blocked. Under the most used set of rules (OWASP rules), some of our plugin’s requests were being detected as “suspicious” and thus were blocked. We fixed that, but there’s no way of telling what can happen under a completely different set of rules.

    It would help to know which mod_security rules SiteGround uses (in their documentation they only say that “they update them every week”), so we can try to make our plugin be considered “safe” under those rules too.

    Regards,

    @painterofthreads – Ivan Atanasov here. I am part of the Senior Support team at SiteGround.

    It is likely that the process you are reporting is hitting one or more of our mod_security rules.

    If you post a ticket from your User Area -> Support and pass me the ticket ID, I will gladly check and attempt to reproduce the problem. It should allow me to catch the ID of the exact rule that is limiting the operation.
    (Please include details instructions in the ticket which will allow me to reproduce the problem)

    @ivanatanasov I have posted a support ticket on the siteground site. Can you let me know what you will need to help?

    ticket # 2175955

    Thanks

    I had Siteground look into this, here is the error code: <b>Fatal error</b>: Call to a member function get_all() on null in <b>/home/threadpa/public_html/wp-content/themes/mystile/functions/admin-functions.php</b> on line <b>3093</b><br />

    They do not think this is a server issue and put it back to WooCommerce and the plugin, is it possible it is the theme mystile this is having an issue with?

    Plugin Contributor danreylop

    (@danreylop)

    Ok, so the issue with mod_security is definitely fixed, that’s some progress 🙂

    I fail to see how our plugin could conflict with the mystile theme in that way. In the line 3093 there’s nothing that could fail, at least in the official theme. Could you please remove the modifications you’ve made to the theme, and try again? I’ve just installed the mystile theme in my testing site and everything is working fine.

    I have a child theme off of mystile, could that be causing the issues? I have not made any modifications, I tried deleting the plugin and re-installing it and I am still experiencing the same issues. I would love it if this can actually work.

    Plugin Contributor danreylop

    (@danreylop)

    Yes, that could be the problem. What’s the theme you’re using? If it’s publicly available, I can install it in my testing site so I can try to reproduce the error.

    In the meantime, please try using the mystile theme instead of a child theme to confirm that the problem is caused by the child theme.

    If changing to a different theme doesn’t solve the issue, please open a WooCommerce support ticket with a link to this thread (then respond here with the Ticket Number so I can get notified and take a look at it). You can attach there a Ssystem Status Report, which is basic information about your store, like all your installed plugins versions and some general basic configuration. Here is a link to do so: https://woocommerce.com/my-account/create-a-ticket/

    Thanks for keeping trying to solve this instead of giving up on the plugin! These kind of incompatibilities are expected the first weeks/months a plugin is released to the public, because nobody can test all the plugins, themes, or hosting configurations in the world 🙂

    • This reply was modified 3 years, 7 months ago by danreylop.
Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Can’t configure Canada Post Shipping Zone’ is closed to new replies.