Support » Fixing WordPress » Can’t comment! What have I done?

  • miaow

    (@miaow)


    I had a spasm a week or so ago when I was being continually swamped with spam and removed the comment function from my blog. I took this out of my main page:
    ‘<div class=”feedback”> <?php wp_link_pages(); ?> <?php comments_popup_link(__(‘Comments (0)’), __(‘Comments (1)’), __(‘Comments (%)’)); ?> </div>’
    Since then I have implemented the latest version of the wpblacklist plugin and it’s working like a dream (I couldn’t make the older versions work). So I have put that bit of code back in – so it looks right on the page, but when you click to comment there is no option to do so. I must have done something or tweaked something in a moment of spam induced fury and I can’t remember what it was! Argh! Can anyone suggest anything I might try?
    [m i a o w]
    :o(
    B

Viewing 5 replies - 1 through 5 (of 5 total)
  • adeydas4

    (@adeydas4)

    Put this code in place of what you’ve put:
    <div class="feedback">
    <?php wp_link_pages(); ?>
    <?php comments_popup_link(__('Comments (0)'), __('Comments (1)'), __('Comments (%)')); ?>
    </div>
    <!--
    <?php trackback_rdf(); ?>
    -->
    <?php include(ABSPATH . 'wp-comments.php'); ?>

    You just missed the last part which calls wp-comments.php for the comments and trackbacks.
    Abhishek.

    miaow

    (@miaow)

    Oh thank you.
    Perfect!

    Oh no. Now something else has gone wrong. My wpblacklist stopped working – I managed to fix it, but since then you can’t post comments on my page. No errors. Nothing! It just reloads like you never even left a comment. I have just deactivated wpblacklist and tried and the comments work fine. But now I will be spammed to death. Has anyone else had this problem?
    [m i a o w]

    Is the blacklist still off? Because I could post a test comment (you should delete it, of course).
    I don’t remember any other post with a similar problem. What did you do when you “managed to fix” wpblacklist?

    Oops. OK.
    For starters, I “managed to fix” it originally by deleting the ‘blacklist’ table in my WordPress db via phpadmin. That fixed the problem I was having (which was that comments were working, but an error page would come up as soon as you posted one so that you didn’t know whether it had worked or not).
    Anyway, after a bit more poking around, it seems that my current problem is “a bug in WPBlacklist 2.62 about entering null/space in the database“. So I’m going to try and use the suggested hack and see if that helps.
    Oh – and finally – thanks for getting back to me so quickly! And yes – I’ve still got wpblacklist turned off ;o)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can’t comment! What have I done?’ is closed to new replies.