Support » Fixing WordPress » Can’t Comment at all…

  • Hello,

    I’ve finished setting up my website with a blog and custom pages. Everything works fine, even after upgrading to WP 2.2.
    The only thing that didn’t work in 2.1.3 and also now in 2.2 is placing comments.
    Here’s a page:
    http://www.raymondhaaken.nl/2007/05/24/goeie-films/#respond

    All I see is:

    Leave a Reply
    You must be logged in to post a comment.

    And afaik I AM logged in, and a friend of mine who tried to comment was also logged in but couldn’t find any way to leave a comment, no frame to type text in, no popup or anything.

    I tried the standard theme, an unmodified theme, and my own theme, but it’s all the same.

    What am I doing wrong / overseeing here?
    PS: I’m no php genious, I just manage to dabble in WP.

Viewing 9 replies - 1 through 9 (of 9 total)
  • *bump* please help. can’t figure it out…

    another desperate bump…

    It seems, that after you’re logged in, the site doens’t recognize you as being logged in and tells you that you must log in to comment, while you already are…
    Maybe that’s the fault? Somehow the site doesn’t know you’re logged in???

    I really need help here…

    whooami

    (@whooami)

    Member

    and when you use the default theme, what do you see?

    as I said in the 1st post:

    I tried the standard theme, an unmodified theme, and my own theme, but it’s all the same.

    I’m gonna try a whole new fresh page, with unmodded php files, and just copy paste my own custom pages into the theme, and see what happens…

    I’ve upgraded to WP 2.2, clean start, uploaded a new, clean, theme. Activated it all without problems, looked at my page, and still no comment boxes, only the message: You must be logged in to comment, which I AM… *RAAAH* :'(

    If I UNcheck the option “users must be registered and logged in to comment” it works, but I only want registered users to be able to comment.
    So I seem to have found the error here.

      If I check the “users must be registered and logged in to comment” option, the comment box disappears, and users are asked to log in, even if they are allready logged in!!

    Could it be my MySQL database??? (I also have a forum, and that works just fine by the way…)

    Or could it be WP 2.2 itself?

    Anyone???

    I’m actually running into this same thing. Anyone have a resolution for this?

    Wow…I just realized I am having the same problem. Never knew it before until I read your post and tried it on my own blog. Does anyone have a solution for this? I do not have the box checked that requires people to login before they post, yet it is making them do so. This probably explains why I haven’t had any comments on my blog since I started it. :o(

    OOOPS! I just checked my admin and that box WAS checked after all. I have unchecked it and have corrected the problem on our blog. For those of you experiencing the same problem, double check your settings. I swore mine was unchecked, but I was wrong. Hope this helps resolve your problem.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t Comment at all…’ is closed to new replies.