Support » How-To and Troubleshooting » [Resolved] can’t comment

[Resolved] can’t comment

  • Hi there! When I click on “Comments” in order to leave a comment for a post, it gets me to the actual post, with no ‘comment form” at the bottom for me to fill in. I am using the latest wordpress version and the theme I am using came with just an “image folder”, the “CSS file” and an index.php file to replace the default one (it was originally made for WP 1.2). I’ve followed every step on this tutorial – http://codex.wordpress.org/Upgrade_1.2_to_1.5#Upgrading_Old_Templates_-_Easy – on how to convert a theme from WP 1.2 to WP 1.5, and still, no comment form when I click on “comments”. Has anybody encountered such a problem before? My webpage is at http://blog.alexlimoges.com
    Any help would be much appreciated, thanx!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Apparently your theme has a single.php; does that include:

    <?php comments_template(); ?>

    somewhere in The Loop?

    Yup, it seems to be there…
    You can view single.php at http://blog.alexlimoges.com/single.txt
    Thank you for your suggestion Kafkaesqui 😉

    I’m not seeing that template reflected in your single post pages. Rather, it looks like all query types may be using index.php.

    would there be a way then to include <?php comments_template(); ?> in my index.php somewhere? I dunno where though, but it seems that my theme calls everything from that file…

    Just place it in The Loop where it seems appropriate. Look for <?php trackback_rdf(); ?> and try inserting it right after this.

    Note that comments_template() is “query aware”, which means it will only display comments and the comment form on a single post or Page. So placing it in index.php is not an issue.

    OK good thanx! It works, I’ve a box waiting for me to type in a comment 😀
    However, the box is very big and it kinda go off the borders…any suggestion to correct that as well?


    Look for this in your style.css:

    #commentform textarea {
    width: 80%;

    and change it to:

    textarea#comment {
    width: 80%;

    You can similarly edit or add properties for the rest of the edit form id’s, classes and html elements.

    hum…that didn’t seem to work…it still is off..
    Thanks so much for your help btw!

    and oh, I’ve just tried adding a comment and when I click on the “send comments” it doesn’t do anything…

    *Which* style.css are you editing? When I access the source for your site’s stylehseet, it’s at:


    and not the typical


    yeah I know, it’s pretty weird…I gets it at theme/fleur/style.css…which is the one I’m editing…

    Note that your comments_template() seems to reside within the HTML comments surrounding <?php trackback_rdf(); ?>. Make sure it looks like this:

    <?php trackback_rdf(); ?>
    <?php comments_template(); ?>

    oh wow now it works perfect!!!!
    thank you so much!!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] can’t comment’ is closed to new replies.