WordPress.org

Support

Support » How-To and Troubleshooting » Can’t change themes in new WP1.5 install

Can’t change themes in new WP1.5 install

  • Hi

    Finally took the 1.5 plunge and followed the 1.2->1.5 upgrade options at http://www.tamba2.org.uk/wordpress/upgrade/upgrade_en.html.

    I am very pleased with the result, except that I want my old layout restored. At Presentation-Themes, there is only default theme, with no other themes available. Also, it says “The template files are located in . The stylesheet files are located in .”

    I am not sure if I done the chmod thing right, and I cannot find .htaccess file either in smartftp or cuteftp.

    I am grateful for any help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Mark (podz)
    Support Maven

    @podz

    In the /wp-content/themes directory, there should be 3 folders:
    Default
    Classic
    Your theme

    Do you see them ?

    Yep! I can see all them, Your theme is “Carrots” as per the upgrade suggestion.

    I also have a problem now with a blank index.php page (strangely this page displayed perfectly on initial upgrade process).

    Mark (podz)
    Support Maven

    @podz

    Carrots – good word 🙂
    The css there gets a 403
    http://www.llasher.com/wordpress/wp-content/themes/Carrots/style.css
    and so does the classic.

    Try changing the permissions up for those folders ?

    Ok, done that. Plus it kind of works. Can see my index.php now, but only kind of

    http://www.llasher.com/wordpress/

    Some problem with the css file? The default theme works OK, but it is too plain.

    I am grateful though that you fixed the blank index.php. Thanks!

    BTW, what should the permissions be set for the themes folder and files?

    Mark (podz)
    Support Maven

    @podz

    755 should present no problems for you.

    Thanks

    Any ideas why http://www.llasher.com/wordpress/
    looks so, er, minimal.

    In 1.2 I had a particular layout based on the css file which included a banner and graphics that are in the root folder. The colors in the page are right, but obviously nothing else is. I will try to edit the style.css file, but I am not sure why nothing else has translated to 1.5.

    Any ideas?

    OK. I am getting there with this harrowing upgrade! I have updated links in style.css, and the graphic page elements are now taking shape. What I am unsure about is why the content is missing: links, posts, comments etc. It is fine on the vanilla styled theme, so it is there in my database.

    Is there a trick in the upgrade process to make the index page from 1.2 display the content the same way as it did before?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t change themes in new WP1.5 install’ is closed to new replies.