Support » Fixing WordPress » Can’t change theme – WP 2.0

  • I just got WP 2.0 running in a new install. When I go to presentation and select a different theme, it says that a new theme has been activated. But it doesn’t change the theme. I’ve downloaded an additional theme just in case something was wrong with the ones installed, and it doesn’t make any difference.


Viewing 8 replies - 1 through 8 (of 8 total)
  • My first instinct is the simple explanation, browser cache. Try holding shift while clicking reload on your blog after changing the theme, or close the browser altogether and restart it.

    If that doesn’t make a difference – then I’d ask – have you installed the theme switcher plugin? Because if you have, no matter what you set in the wp-admin, theme switcher overrides that with the last chosen theme. You’ll have to select the new theme via the theme switcher on your page to see it.

    It wasn’t cache, I tried those things. I don’t think I installed the switcher, but how would I know? All I have have downloaded and installed is WP 2.0, and Ocadia Theme in the content theme folder. I’ve done nothing more than install, bring in a dozen posts from previous blog and then tried to change the theme.

    You probably don’t have theme switcher installed then… so, honestly, if you’re not getting any errors I don’t really know what would be causing it. Make sure the themes are in the right folder structure (should be wp-content/themes/themename/ — make sure the style.css is in that folder and not a subfolder of themename)… but other than that I can’t even think of anything.


    Okay, thanks for the assistance. Are there any permissions to the file system that are required for picking a theme? Or is all of this stored in the DB?

    When I click on a theme, I see the page refresh a little bit, the cursor turns to an hour glass, on and off about 4-6 times, and then it says a new theme has been activated. (but obviously, the theme doesn’t change at all)

    I believe I’m selecting the theme properly, however the doc is for 1.5 I assume as it talks about a table. All I see is 4 thumbnails of the themes I have available. I clock the thumbnail or the test link for the theme to activate it. Is there somthing else I’m missing?

    I don’t know if this has anything to do with it, but I loaded a plugin, and went to the plugin’s page and selected activate. Even though the top area says the plugin was activated, the link for activate is still there.

    Anyone have any idea of what’s going on? I’m running on a hosted windows server if that makes any difference.

    There’s a *slight* possibility that it’s a permissions issue (though I doubt it). Check to make sure that all of your file permissions match this document:

    Just for fun, try deactivating all plugins and see if you can change themes then. (There could be a funky plugin you’ve installed.) If it works, then you’ll need to activate the plugins one at a time and re-test to find out which one is the culprit.

    But those are both stabs in the dark. Without access to your host and your WP admin, I can’t think of any other reason.

    Yes, it was definitely permissions. I gave everyone full permissions and it now works for both plugins and themes. So I need to figure out what user actually needs access.

    Hi there,

    mjulson: what do you mean when you say that you “gave everyone full permissions”? Does that mean you changed all directories to mode 0777 and all files to mode 0666?

    I went through the same issue today, but found a much different solution:

    Could you elaborate on your full permissions solution? I was about to submit a bug report, but now I’m not sure about what the problem is.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can’t change theme – WP 2.0’ is closed to new replies.