Support » Plugin: Yoast SEO » Can't change SEO information on frontpage

  • Hi guys,

    after the last Yoast update, I can’t change the SEO information for the frontpage. Whenever I change (and save) it, it keeps changing back to the SEO information of a blog post.

    It only happens with the frontpage. All the other pages still have their right SEO settings.

    Is there a way to fix that?

    https://wordpress.org/plugins/wordpress-seo/

Viewing 14 replies - 1 through 14 (of 14 total)
  • I am having a similar problem. My homepage is the default page that shows the most recent comments, but I don’t know how to make it search engine friendly, as there is no page to edit!

    same problem! all the problem will come after I add a blog post shortcode in any new page, if you delete the shortcode (or blogpost) from your page, there is no problem!

    Same thing for me: “after the last Yoast update, I can’t change the SEO information for the frontpage. Whenever I change (and save) it, it keeps changing back to the SEO information of a blog post”.

    I will add that the permalink for the post doesn’t work anymore since its hacked by the homepage: ie. the reader is redirected to the homepage when he is trying to reach the blog post. Even if I change the permalink for the post it doesn’t work.

    How do you make your homepage SEO friendly, if you are displaying your most recent posts? There is no static page to try and modify to become more SEO friendly, it’s just a page that is generated on demand.

    Hi, i have had this problem on some sites, a changed to the default theme, filled out the SEO nad updated. Then changed back to my real. That is a workaround even if it is more work.

    I’m having the same issue.

    How do you mean you changed it back to the default theme, what is the default theme? Do you mean your parent theme?

    There is no ‘homepage’ in the list of pages, if you have your homepage set as your most recent content (rather than a static page), so I don’t know how to edit it and make it SEO friendly.

    I’m sure Yoast/Wodpress wont mind me posting this comment becuase competition is what drives better products!

    I deleted Yoast and installed All In One SEO, and I kid you not, my homepage now lists as 3rd on Google. When I used Yoast, not only did the homepage NOT show on Google’s front page, but the Archive/Category pages (The stuff you dont really want to be listed before the homepage) was about 7th!

    I do not work for All In One, nor do I hav an affiliate program with them.

    Are any of you using the ENfold theme ? If so: read this: http://t.co/TEQVEwwWOe

    thanks jrf, I’m using enfold and I will try your solution.

    Thanks JRF, I guess your solution will work due to using enfold as theme by me, but I have changed my SEO plugin and now I’m using All in Seo Pack

    Thanks jrf! That’s the solution to my problem!

    Hi,

    We have the same problem, we cannot change the SEO information for the frontpage of our site Bigseo. Could it be maybe because we have a custom WordPress theme developed?

    This theme has modified directly the index.php archive to set up the frontpage, it is not a page set as frontpage. this is what it have:

    <br />
    <?php<br />
    /*<br />
    *<br />
    *	Plantilla la página principal<br />
    *<br />
    */<br />
    ?><br />
    <?php get_header(); ?></p>
    <p><?php //suscripcion(); ?><br />
    <div id="bigseo-home"><br />
    <?php index_section_one(); ?><br />
    <?php index_section_two(); ?><br />
    <?php index_section_three(); ?><br />
    <?php index_section_four(); ?><br />
    <?php index_section_five(); ?><br />
    <?php index_section_six(); ?><br />
    </div></p>
    <p><?php get_footer(); ?><br />

    And the sections are inside an archive called sections.php, ¿could be any of this the origin of the problem? Should we create a page, add the sections there and then set it as the homepage in the WordPress>Settings ?

    Thanks for your help.

    @romualdfons This topic is eleven months old and addresses a different issue. Open a new topic.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can't change SEO information on frontpage’ is closed to new replies.