WordPress.org

Support

Support » Plugins and Hacks » SendPress Newsletters » [Resolved] Can't Change Sending Speed And Limit

[Resolved] Can't Change Sending Speed And Limit

  • SendPress is working beautifully… EXCEPT the show-stopper that I cannot change the speed limits. Trying to change either the number or frequency fails with the error below.

    Any help greatly appreciated.

    ———————-
    I get this error (with … representing my server path)

    Fatal error: Uncaught exception ‘Exception’ with message ‘Could not find caller class: originating method call is obscured.’ in …/wp-content/plugins/sendpress/inc/functions.php:99 Stack trace: #0 …/wp-content/plugins/sendpress/classes/views/class-sendpress-view.php(57): get_called_class() #1 /…/wp-content/plugins/sendpress/classes/views/class-sendpress-view-settings-account.php(39): SendPress_View::redirect() #2 … /wp-content/plugins/sendpress/sendpress.php(674): SendPress_View_Settings_Account->account_setup() #3 …/wp-includes/plugin.php(406): SendPress->admin_init() #4 …/wp-admin/admin.php(111): do_action(”) #5 {main} thrown in …/wp-content/plugins/sendpress/inc/functions.php on line 99

    Here’s the debug.

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: No

    SITE_URL: http://HumanRightsDefendersLeague.ca
    HOME_URL: http://HumanRightsDefendersLeague.ca

    SP Version: 0.9.2
    WordPress Version: 3.5.1

    Platform: Apple
    Browser Name: Safari
    Browser Version: 5.1.7
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10_6_8) AppleWebKit/534.5
    7.2 (KHTML, like Gecko) Version/
    5.1.7 Safari/534.57.2

    PHP Version: 5.2.17
    MySQL Version: 5.1.67-rel14.3-log
    Web Server Info: Apache

    PHP Memory Limit: 256M
    PHP Post Max Size: 12M

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 3 Status: Acceptable

    Show On Front: page
    Page On Front: Human Rights Defenders League #464
    Page For Posts: Human Rights Defenders League #464

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: Off

    UPLOAD_MAX_FILESIZE: 10MB
    POST_MAX_SIZE: 12MB
    WordPress Memory Limit: 40MB
    WP_DEBUG: Off
    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.

    ACTIVE PLUGINS:

    Advanced YouTube Embed Plugin – Embed Plus: 2.4.0
    ET Anticipate Maintenance Plugin: 1.6
    Jetpack by WordPress.com: 2.2
    Participants Database: 1.4.9.1
    SendPress: Email Marketing and Newsletters: 0.9.2
    Visual Form Builder: 2.7.1

    CURRENT THEME:

    Responsive: 1.9.0

    ### End System Info ###

    http://wordpress.org/extend/plugins/sendpress/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author itdoug

    @itdoug

    It’s probably because you are running php 5.2. We are testing the next release which should fix that. Hope to have it out this week.

    Oh, goodie! 🙂

    I talked to our upline and they gave me an .htaccess line to add

    AddHandler application/x-httpd-php53 .php

    This fixes the server error when attempting to set the Sending Speed And Limits, however the settings immediately revert to the defaults instead of actually changing.

    Correction: further fiddling reveals I can’t change the limit to 0 for no limit.

    I can change it to 10,000 and the speed to 600 for example and it stays. But if I try setting the limit to 0… poof! resets both fields to the default.

    SO, I’m good with that, but might be a clue for you folks.

    Plugin Author Josh Lyford

    @joshl

    Hi Kent,

    Thanks for all the testing. I have written up an issue for setting limits to 0. This did not make it into 0.9.3 but will be in the next release.

    Best,
    Josh

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Can't Change Sending Speed And Limit’ is closed to new replies.
Skip to toolbar