Support » Plugin: Image and video gallery from Google Drive » Can’t Change Root Directory

  • Resolved allankessler

    (@allankessler)


    Hi, I tested your plugin and found it does exactly what I want. Thanks for creating it. For testing I used my existing Google Drive but for actual use I wanted a Google Account dedicated to the web site. I created this and duplicated the steps. It all worked well although I found I couldn’t change the Client ID and Client Secret. So I revoked the permission and was able to change these and I can Grant Permission and Save Changes. However when I go to Root Directory Selection I cannot change the test root directory name to what I want for production. I have tried various combinations of Granting Permission and Saving Changes which seems to be all I can do but still cannot change this setting.
    Can it be changed and if so how?
    If not, do I need to uninstall the plugin and start again? Will that work?
    Thanks
    Allan

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Marek Dědič

    (@marekdedic)

    Hi,
    yeah, this is a known issue, I didn’t really count on people changing IDs… We have it in our bug tracker on GitHub, so it will get fixed eventually.

    In the meantime, uninstalling the re-installing the plugin should fix the issue. Unfortunately, it will also purge all the settings.

    Hope you get it working,
    Marek

    Thread Starter allankessler

    (@allankessler)

    Hello Marek

    Thanks for the quick response and for creating a great plugin.

    I searched GitHuB but there were no hits on “root”.

    I’ll uninstall and re-install. A little extra work but shouldn’t be a problem if it regenerates all the parameters the same. Not being a developer the Google side was harder. I found some issues with the instructions. I think I didn’t tab/click out of a field and then saved which resulted in that field not being saved.

    I had a problem with “Authorised redirect URI” because your system generates it preceded by http;// but Google does not accept the http (nor https) its says.

    I saw some of the issues that others have reported but by going back through, checking and correcting it came right.

    Thanks again
    Allan

    Plugin Author Marek Dědič

    (@marekdedic)

    Yeah, well, it’s this one…

    https://github.com/skaut/skaut-google-drive-gallery/issues/102

    I try to get everyone use English in the bug tracker, but people just keep creating issues in Czech…

    With the redirect URI and the Google app setup we have some trouble as Google keeps changing the process what seems to me to be like twice a month. Thanks for the notice.

    Marek

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can’t Change Root Directory’ is closed to new replies.