[resolved] Can't Change Post Title Font in Twenty Ten (8 posts)

  1. harrietdh
    Posted 3 years ago #

    I have tried everything. I have read every post on this forum and google searched this problem to death. For some reason the twenty ten theme won't let me change font.

    I am working with a child theme.


    Is the entry-title font specified somewhere other than the style.php file? When I change the font in the font family line for the group that includes the .entry-title, NOTHING happens. Font stays the same. I can change color but not font style.

    Ultimately I would like to change the font of the post titles to custom font using Cufon - but it's not working at present at all. Probably because changing the font family is doing nothing.

    Thanks for your help!

  2. WPyogi
    Forum Moderator
    Posted 3 years ago #

    First you need to get that style.css file set up correctly - it should not be a copy of the parent style.css file.

    The top should have:

    Theme Name:     Twenty Ten Child
    Description:    Child theme for the Twenty Ten theme
    Author:         Beata
    Template:       twentyten
    Version:        0.1.0
    @import url('../twentyten/style.css');

    You're missing the @import line.

    After that put ONLY changes you are making to the parent theme styles.

  3. WPyogi
    Forum Moderator
    Posted 3 years ago #

    After you've fixed that, try this for changing the font:

    #content .entry-title {
        font-family: .......;

    Note that you may need to use a plugin to add non-web-safe fonts - something like this:


  4. harrietdh
    Posted 3 years ago #

    I added the @import line, but adding only the changes I am making is going to be a problem, since I made a lot of changes. Is this the reason my font won't change?

    Also, adding the #content .entry-title line did nothing for changing the font.

  5. WPyogi
    Forum Moderator
    Posted 3 years ago #

    You can use a file comparison program like diffchecker to find your changes - so you can move those to the child theme style.css file.

    Check on these errors - they may be preventing your changes from working yes.


  6. harrietdh
    Posted 3 years ago #

    Ok, changed all of the stle.css to only reflect changes. Also, ran it through the checker, and no errors were found.

    Font still not changing. Help!

  7. WPyogi
    Forum Moderator
    Posted 3 years ago #

    That's working on my computer... clear your browser cache.

    What browser are you using?

  8. harrietdh
    Posted 3 years ago #

    Yep, working now. I'm using firefox.

    Thanks for your help and your patience.

Topic Closed

This topic has been closed to new replies.

About this Topic