Support » Plugin: Multisite Language Switcher » Can’t change language in settings – general

  • Resolved cielle

    (@cielle)



    Hello, thanks for a great plugin!!!

    I have downloaded the Greek language files to my wordpress installation and indeed the backend of it is in Greek!!! BUT on my settings page it shows up as English(United States)! and even though it gives me the choice to choose Greek, it is available and installed (and I want it to say Greek because I want it to change the language settings on a plugin I am using… ) when i save it, it goes back to/just stays in English!! I am not sure why this is happening… Thank you, i hope my problem/question is clear…

    And of course, I am using wordpress multisite and multisite language switcher plugin. My webhosts who were trying to help me with this problem, suggested that it was perhaps your plugin causing the issues..

    They suggested also to uninstall it and re-install ( because just deactivating it made no difference… ) . I have not done this yet. I was wondering, if i do this, will I lose all my settings, will it be a lot to set up again?? ( I set it up quite some time ago now!!! )

    Thank you so much for your help!!!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Dennis Ploetner

    (@realloc)

    There is no difference between the deactivation and uninstalling the whole plugin. because there is simply no other task that will be executed. I think your problem could be a setting of WPLANG or similar in wp-config.php … could you check if you have set a language in that file?

    Hey Dennis, thanks for your reply!!
    great, so I won’t uninstall then…
    I looked at wp-config.php and the only mention of WPLANG that I see is:

    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
     * language support.
     */
    //define ('WPLANG', 'el');

    Is this ok? Does it need to be changed??

    Thank you!

    Plugin Author Dennis Ploetner

    (@realloc)

    It seems it that WPLANG is commented. So there is no problem … do you have other plugins installed that could cause the problem?

    i have a bunch of other plugins installed yes… I suppose I should go through and de-activate them all and try to change the language then? fun…

    Plugin Author Dennis Ploetner

    (@realloc)

    Yes, I’m sorry but give it a shot since you already tried it with the Multisite Language Switcher.

    Hello I have the very same problem on my site too.. i have tried to deactivate all plugins and it still wont work. Any idea ?

    Plugin Author Dennis Ploetner

    (@realloc)

    Did you deactivate also the Multisite Language Switcher to exclude this plugin too?

    cielle

    (@cielle)

    Hello again Dennis, well i tried deactivating ALL plugins and that still did not help… BUT!!!

    I found ( with the help of support at Elegant Themes – I am using Divi Theme from them… ) the solution!!!

    This is what they said to do and it worked!!!

    “Sorry for the trouble. Could you go to Divi → Theme Options → General → Disable Translations and make sure that they are disabled and then recheck? Let me know how it goes.”

    So thank you again for your time and for a brilliant as ever plugin… xx

    Thanks! Had the same issue!

    really glad to be of help… know how frustrating it can be! 🙂

    dozza

    (@dozza)

    @cielle

    I love you!

    Had same issue on multiple Divi sites

    cielle

    (@cielle)

    @dozza

    Let’s get married! 🙂

    Just kidding, love you back… xx

    Thanks @cielle, I had the same issue with Divi! 🙂

    @papireper, really pleased that I helped and that you found a solution! xx

    Thank you so much.
    I had the same issue with Divi and was looking for a solution for quite some time.
    Didn’t know Divi was the problem -:)

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.